[fedora-virt] P2V and grub bootloader

Dennis J. dennisml at conversis.de
Fri May 1 13:57:39 UTC 2009

On 05/01/2009 02:55 PM, Richard W.M. Jones wrote:
> On Fri, May 01, 2009 at 02:34:22PM +0200, Dennis J. wrote:
>> I've rebuilt all of those and installed them:
>> febootstrap-1.7-1.fc10.1.noarch
>> fakechroot-2.9-22.fc10.i386
>> fakeroot-1.12.2-21.fc10.i386
>> qemu-0.10-15.fc10.i386
>> Also I'm using the brand-new libguestfs-1.0.18-1.fc11.src.rpm to try to
>> rebuild it for f10 but I still get fatal errors:
>> Lots of these:
>> /usr/bin/pod2html: inspector/virt-inspector.pl: unknown pod directive
>> 'encoding' in paragraph 5.  ignoring.
>> /usr/bin/pod2html: inspector/virt-inspector.pl: cannot resolve
>> L<guestfish(1)>  in paragraph 44.
>> /usr/bin/pod2html: inspector/virt-inspector.pl: cannot resolve
>> L<guestfish(1)>  in paragraph 69.
>> /usr/bin/pod2html: inspector/virt-inspector.pl: cannot resolve
>> L<guestfs(3)>  in paragraph 139.
> Ignore these, they're just documentation warnings.
>> Then I see this:
>> malloc: 4103338240: Cannot allocate memory
>> DB_ENV->set_lk_detect: unknown deadlock detection mode specified
>> DB_ENV->txn_stat_print interface requires an environment configured for
>> the transaction subsystem
> These seem to be from the Python BerkleyDB library.  Trying to
> allocate 4 GB of memory, nice one Python.
> I don't have a Fedora 10 i386 box to test against, but my suggestion
> is to upgrade to the latest Yum (especially) and Python (if possible)
> from F11/F12.
> This is what I'm using on F11 i386:
> $ rpm -q python yum
> python-2.6-7.fc11.i586
> yum-3.2.22-4.fc11.noarch

I updated yum but still get the segfault but the malloc error didn't reappear.

Updating Python really isn't an option as that basically forces a 
distribution upgrade anyway due to its massive dependency tail.

In the line:
run_yum: line 1: 13054 Segmentation fault      yum -y -c 
"$tmpdir"/febootstrap.repo --disablerepo=* --enablerepo=febootstrap 
--noplugins --nogpgcheck --installroot="$target" install "$@"

what are the contents of "$tmpdir/febootstrap.repo"? I tried finding it in 
the build directory after the failure but (also run_yum) but I couldn't 
find them anywhere. I want to execute that command manually in order to 
track down the cause of the segfault.


More information about the Fedora-virt mailing list