[fedora-virt] P2V and grub bootloader

Dennis J. dennisml at conversis.de
Fri May 1 14:16:23 UTC 2009

On 05/01/2009 03:49 PM, Richard W.M. Jones wrote:
> I just uploaded some Fedora 11 / i586 binary RPMs to the site:
> http://et.redhat.com/~rjones/libguestfs/files/
> These _may_ work on Fedora 10, I haven't tried.  They will certainly
> require qemu>= 0.10 from Fedora 11 though.

This seems to work nicely for me on f10 so far, thanks!

The grub-install command still doesn't work though:

[root at nexus ~]# guestfish -a /var/lib/libvirt/images/test.img -m 
qemu: loading initrd (0x15b0c16 bytes) at 0x000000000b53f000

Welcome to guestfish, the libguestfs filesystem interactive shell for
editing virtual machine filesystems.

Type: 'help' for help with commands
       'quit' to quit the shell

 ><fs> cat /etc/redhat-release
Fedora release 10.92 (Rawhide)

 ><fs> grub-install / /dev/sda
libguestfs: error: grub-install: /dev/mapper/vg_mobile-lv_root does not 
have any corresponding BIOS drive.


More information about the Fedora-virt mailing list