[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

note for http://fedoraproject.org/wiki/YumUpgradeFaq



When upgrading from Fedora 6 to 7, I got a bunch of errors of the form:
  Error: Missing Dependency: python(abi) = 2.4 is needed by package

Although the document on the wiki suggests you may have to remove
rhnlib and update, it fails to mention that that is because those
aren't part of fedora 7 so you don't need them anymore, which would be
comforting for someone doing the upgrades to know.  However, that
wasn't enough.  What I needed to do was:

rpm -e rhnlib up2date 4Suite authconfig firstboot-tui authconfig-gtk firstboot system-config-boot

That got rid of all the packages that triggerred the python(abi)
dependency, allowing me to do a yum update and reboot into Fedora 7.

I was then able to reinstall these packages:
  yum install authconfig firstboot-tui authconfig-gtk firstboot

So I would add a note to the FAQ suggesting removing all of those
packages before the upgrade, and reinstalling the subset that still
exist in Fedora 7 after the upgrade.  I would also have the note
mention that "Missing Dependency: python(abi)" error explicitly, so
that people who see it will know what it's about and what to do.
  -- Cos



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]