local apps how-to

Robert Arkiletian robark at gmail.com
Tue Oct 14 16:34:05 UTC 2008

On Mon, Oct 13, 2008 at 8:56 PM, Warren Togami <wtogami at redhat.com> wrote:
> Robert Arkiletian wrote:
>> Note: I could not find flash-plugin with yum so I copied the file from
>> outside the chroot like this
>> cp  /usr/lib/mozilla/plugins/libflashplayer.so
>> /opt/ltsp/i386/usr/lib/mozilla/plugins/
>> then I installed libflashsupport
>> yum install libflashsupport
> Did you install adobe-release RPM from Adobe within the chroot?  yum will
> not find it if you do not have Adobe release.
> http://macromedia.mplug.org/
> You should really use Flash 10 instead of Flash 9.  Flash 10 works a lot
> better especially for sound.

Good advice, thanks. I installed the Flash 10 rc3 rpm and it works
much better than Flash 9. It will now play youtube videos without
stopping after 2 seconds. However, I still don't have sound.
Oh, ya, I removed libflashsupport rpm from the chroot as your site suggests.

> It is possible that more environment variables are needed to direct a local
> app to use the pulseaudio daemon.  You might want to check with upstream, I
> recall they tackled this recently.

Tried googling for these environment variables but couldn't find them.
I only tried
but that didn't work.

> Also make sure you are using the LATEST builds of ldm, ltspfs and ltsp on
> both your server and client chroot.  Latest builds were yesterday.

Can I make sure I have these by doing a yum update inside and outside
of the chroot?

>> Unfortunately,  I still could not get flash to work with sound. In
>> addition, launching firefox on a 1.4GHz Athlon with 256MB client with
>> a 100mbps connection takes over 30 seconds.
> Over 30 seconds the first time, or even subsequent times on the same user?

I have something interesting to report:
With 256MB on client firefox was not any faster launching it the
second time around but after I upgraded to 512MB the second launch
went down to 3-4 seconds from an initial 30. So it seems for firefox
to be kept in cache locally, 256 is not enough.

BTW is the firefox binary downloaded to the client through ssh or nfs?

Robert Arkiletian
Eric Hamber Secondary, Vancouver, Canada
Fl_TeacherTool http://www3.telus.net/public/robark/Fl_TeacherTool/
C++ GUI tutorial http://www3.telus.net/public/robark/

More information about the K12Linux-devel-list mailing list