[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] Frustration



I knew that issues with isa cards had been discussed before so I did a
google search on (ltsp.org isa nic) on google.com.

The very first result was a helpful post by Jim McQuillan:

https://listman.redhat.com/pipermail/k12osn/2002-February/000106.html

He refers to the documentation at
http://www.ltsp.org/instructions-3.0.html .... some file called
instructions-3.0.html - imagine that...  ;-^)

Here's the part that might help:

Quoted from Jim's web page:
ISA Network cards

The LTSP kernels can automatically detect the network card, if it is a
PCI card. If it is not, then you have to specify which network card
driver to load. And, some ISA network cards also require an IO option to
be passed to the module.

You can specify the NIC driver and IO address by adding an entry to the
individual host section of the dhcpd.conf file. Here's an example for a
workstation with an NE2000 network card:


    host ws001 {
        hardware ethernet     00:E0:06:E8:00:84;
        fixed-address         192.168.0.1;
        filename              "/lts/vmlinuz-2.4.18-ltsp-1";
        option option-128     e4:45:74:68:00:00;
        option option-129     "NIC=ne IO=0x300";
    }

There is a very important thing to notice about the example above. The
value specified for option-128 is NOT a mac address. The value
e4:45:74:68:00:00 is a special value that Etherboot requires. If it is
not there, or is something other than the value above, then all of the
other extended options will be ignored by Etherboot.

End Quote...

I hope this helps.

;-) Paul 

On Sat, 2002-12-07 at 03:23, Dave Prentice wrote:
> Help, anybody!
>     For 3 months I've been trying to get a classroom LTSP network
> operating. The server seems fine, but I have yet to be able to get
> even a single client to work. I received a generous donation of 3C515
> 100mb NICs, which are ISA so as to run in my old 486s. I downloaded a
> boot image for that card from rom-o-matic. I have tried to boot 5
> machines (Compaq 486s) so far with this NIC but get a message on the
> screen that the boot program found the 3C515, followed immediately by
> an "adapter not found" message and another attempt to boot.
>     I tried several other types of (10mb) NICs, but not a single type
> that I have (eexpress, 3c509, SMC EtherEZ, etc.) has a boot image on
> K12LTSP or rom-o-matic. Here's a simple way to find out if a NIC is
> supported: if I have it, it isn't.
>     Please don't suggest that I buy a bunch of stuff. The point of
> K12LTSP is supposed to be that it runs on old, recycled equipment. My
> school district refuses to support anything but MS, so any expense is
> out of my (very empty) pocket. I am so frustrated with LTSP that I am
> ready to throw it all away. I do not know a single person familiar
> enough with it to give me some on-site support. Is anybody on the list
> near southeast Louisiana?
> Thanks,
> Dave Prentice
> prentice instruction com
> 
> 
> 
> 
> _______________________________________________
> K12OSN mailing list
> K12OSN redhat com
> https://listman.redhat.com/mailman/listinfo/k12osn
> For more info see <http://www.k12os.org>
-- 
======================================================================
Paul Nelson .............................. pnelson riverdale k12 or us
Riverdale High School .................. http://hs.riverdale.k12.or.us





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]