[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] connection is up, but attempts to access the internet allfail



Hi Anthony,

Let me get this straight.

You have an ADSL modem (internal or external?) connected to the internet
The machine you are having problems with is connected to the ADSL modem.

I take it you aren't going through a proxy.

Are you using the K12LTSP cds or a straight Redhat distro?

=================

Before you start, draw a block schematic of your network setup. Include
IP addresses and netmasks of devices.

DO NOT write down the IP addresses from memory. You MUST physically
check each address and netmask for each interface.

EG.

'Net
|
|
|
IP = x.x.x.x Netmask x.x.x.x   (assigned by ISP)
------
ADSL
------
IP = 192.168.1.254 Netmask 255.255.255.0
|
|
|
IP = 192.168.1.1 Netmask 255.255.255.0
------
PROXY
------
IP = 192.168.0.1 Netmask 255.255.255.0
|
|
|
IP = 192.168.0.x Netmask 255.255.255.0 (assigned by DHCP server on LAN)
------
Workstation
------

Notice how the subnets and netmask match. If they don't you'll come a
cropper.

If you notice any inconsistencies when you've diagrammed the setup, you
need to fix them first then retest.

If everything is correct then you need to test the network connections.

=====================

Here is a set of steps for testing your network connections. This is
basically what Duane suggested.


1) Ping an internet IP address from you ADSL modem. 
This tests your connection with the rest of the world. If it isn't
working fix it, then retest by pinging then web browsing.

If it is an external modem you may be able to telnet or connect directly
to it and ping from there. Externals may have a web based admin tool.
This should be able to give you some idea of a connection to the 'net.


2) Ping a known IP address on you LAN. If you have a proxy server then
this is the address you will ping.
This tests connections to your LAN / proxy. If it's broken fix it, then
retest by pinging then web browsing

3) IF you have a proxy
    a) PING your ADSL modem
This test outgoing from your proxy to the ADSL modem.
    b) PING an internal address
This tests connections to the LAN from the proxy.
If it's broken fix it then retest by pinging then web browsing

4) From a workstation on the LAN
    a) PING your proxy /adsl modem
This test outgoing connection from the workstation to the proxy /adsl.
    b) PING another machine on the network, if you have more than one   
       workstation.
This tests internal communication on the LAN.
If it's broken fix it then retest by pinging then web browsing

If PING doesn't work it's a network config issue.
If web browsing doesn't work it's a software config issue.


====================================

Software config.

Ensure the proxy server settings have been set in the program. 
Possible areas to look are-
a) KDE Control panel proxy settings
b) Web browser proxy settings
c) E-mail client proxy settings
d) NIC settings in you proxy server software
e) Port settings in your proxy software

Check your workstations to see if they are running multiple protocols,
EG Appletalk and TCP/IP or IPX/SPX & TCP/IP

I've seen situations where the user had access to the network but not
the internet. TCP/IP wasn't installed therefore no 'Net access.

Cheers,
Bert

BTW - I've had lots of messages "ignored". 
Sometimes it's simply the time zone difference, it's 0900 Monday 9/12
here, but you will receive this message sometime Sunday back in the
states.
Sometimes it's mail server problems.
Sometimes we're all busy :-)

On Sun, 2002-12-08 at 15:04, anthony baldwin wrote:
> My first request for assistance with this issue was summarily ignored.
> I'm a little stupefied.  I have never been just ignored, no matter how stupid
> my questions were...
> In any case.  I have built a box out of spare parts and it is up and running
> with our k12os 2.0 (RH 7.3).  I had difficulty connecting to the internet via my
> DSL connection.  
> Since my first request for assistance, I recalled that in the 7.2 based k12 the roaring penguins pppoe software was required, so I downloaded it and moved it over to the other machine (floppy) and installed it.  Then I ran adsl-setup again.  Now it says to run
> /usr/sbin/adsl-start instead of /sbin/ifup eth0 to connect.
> So, I run /adsl-start and it says "Connected!"
> Yeah!!!
> but, wait...don't get excited so quickly...
> When I try to access the internet from any of the browsers here (Moz, Konq, Gal),
> every attempt gives an invalid host or file not found, as though I am not 
> connected at all.  /adsl-status indicates that the connection is up, but attempts 
> to access the internet all fail.
> An attempt to run /sbin/ifup eth0 still indicates failure to determine an ip.  (server assigned/dynamic)
> I'd like to set this box up as a homelan server/router but it won't work it it can't connect.  
> I am supposed to be contributing to my school's upgrade to linux, but if I can't get this to work at home, I'm doomed at school.
> Please help.
> 
> 
> Whaddayathink?
> 
> tony
> 
> http://www.School-Library.net
> Read, Connect, Learn!
> 
> _____________________________________________________________
> Select your own custom email address for FREE! Get you yourchoice com w/No Ads, 6MB, POP & more! http://www.everyone.net/selectmail?campaign=tag
> 
> 
> 
> _______________________________________________
> K12OSN mailing list
> K12OSN redhat com
> https://listman.redhat.com/mailman/listinfo/k12osn
> For more info see <http://www.k12os.org>






[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]