[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] A little progress...



I have a Compaq Presario P133 with a riser board for the expansion slots. I
could not get any isa nic to work for LTSP or a collection of RedHat,
Debian and Suse distros. We tried 3-4 brands of nics. But Windows 9x works
like a champ every time. No amount of twiddling with dhchp or ltsp would
make it recognize an isa nic. I scrapped the Presario for parts. 

Some Compaq designs are very odd. For instance, to access the BIOS of the
Presario above you needed a Compaq diagnostic partition on the local hard
drive -- no local hard drive or no Compaq partition, no BIOS access. We've
had problems with Compaq 486's too. Various members of my LUG won't touch
older Compaq boxes for any reason; they consider them useless for GNU/Linux.

Hans seems to have a promising workaround in compiling the nic module in
the kernel.

Tom

At 09:43 AM 12/11/02 -0500, you wrote:
>Dave,
>
>Take a look at the http://www.ltsp.org/instructions-3.0.html
>
>Down near the bottom of that doc, it explains the option-128
>and option-129 values.
>
>Hope that helps,
>
>Jim McQuillan
>jam Ltsp org
>
>
>
>On Wed, 11 Dec 2002, Dave Prentice wrote:
>
>> Y'all,
>>     Since the 3c515 NIC wouldn't work in the old Compaq 486s, I tried
>> it in a Compaq P90. Finally, it gets pretty far through the boot
>> sequence. However, after doing its DHCPrequest, getting DHCPOFFER and
>> getting responses back and forth with the server several times, it
>> gives the following message:
>> 
>> mounting /proc
>> ERROR! Could not automatically detect the network card.
>> PCI cards should be detected automatically. ISA cards cannot be
>> detected,
>> so they require the NIC driver to be specified in a "NIC=" parameter
>> to be passed on the kernel command line, usually specified in
>> option-129, in the /etc/dhcpd.conf file.
>> Kernel panic
>> 
>>     I went into the etc/dhcpd.conf file and specified the "NIC=3c515",
>> which should be perfectly valid, on option-129. I even put in the mac
>> address of the client's NIC to be tied to a specific IP address for
>> host ws001. So why do I keep getting this message, and what do I do
>> about it?
>>     Perhaps it has something to do with another line in dhcpd.conf,
>> the one that says option option-128. It looks like a mac address also,
>> but it's the same for all the ws00x entries. Any ideas what that line
>> is supposed to say?
>>     Thanks,
>> Dave Prentice
>> prentice instruction com
>> 
>> 
>> 
>> 
>> _______________________________________________
>> K12OSN mailing list
>> K12OSN redhat com
>> https://listman.redhat.com/mailman/listinfo/k12osn
>> For more info see <http://www.k12os.org>
>> 
>
>-- 
>
>
>
>_______________________________________________
>K12OSN mailing list
>K12OSN redhat com
>https://listman.redhat.com/mailman/listinfo/k12osn
>For more info see <http://www.k12os.org>
> 






[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]