[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] home folders on Windows XP



what have you tried for mounting?

I use something like
mount -t smbfs -o username=username,password=password,workgroup=nsup,ip=111.222.333.444 \ //nsupdc1/home/username /home/username/


in your script you will need to replace username, password and ip with the correct values. Sometimes you do not need the workgroup or ip values, but I have found it to be more reliable that way.

type smbmount and hit enter to get a list of available options, you then put these in a comma delimited list after the -o option on the mount -t smbfs command

You also might have to create a named share instead of useing a windows default share home$ we have seen problems with that occasionally.



Kevin Squire wrote:

I figure a short into is in need first --

I have been using Linux now for over 3 years as my personal desktop machine. During this time I have worked for 3 schools, 2 Windows based and 1 Mac based. When I first started using Linux, I learned about the K12LTSP and have been wanting to impement it, just looking for the right time and environment. I have recently (finally) installed a K12LTS for a small lab in my classroom. With a little help from the local LUG, I am using it as a demonstration of the power and benefit of Linux. The IT director and myself also want to do some "beta" testing with students and teachers before impementing it on a full scale.

The problem I have run into is that all the student and teacher "My Documents" folders reside on a central WinXP server, and I need to mount them to the Linux /home/USERNAME/ folder. This of course needs to be done at the time of login, using the student/teachers login name and password. I want it to be as seamless as possible.

I'm sure this problem has been address, or documents somewhere -- I just can't seem to find it. I have searched the archive, I have googled, and I have checked newsgroups, all to no avail. A little help is needed.

I have a "stock" K12LTS install, with all updates and webadm(sp?). I have edited the samba config only as far as to change the workgroup name. I have tried mounting my own home folder manually (from a terminal window) to no avail. The address for the "My Documents" is //nsupdc1/home$/<USERNAME>/ in the only workgroup on our network, nsup

I hope someone can point me in the right direction--
Gentgeen
Teacher









[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]