[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] NFS problems



1. Are you sure nfs is up and running on penguin?  
"service nfs status"

2. When you try mounting /home from the K12ltsp box, run tail -f
/var/log/messages on penguin and you should be able to see the mount
request come in.

3. Did you make an empty mount dir for /home on the K12LTSP box?

4. Do you have a firewall running on penguin that may be keeping it from
accepting nfs requests on that ethernet card?

These are just right off the top of my head. With me it's usually
something silly like #1.

;-) Paul

On Tue, 2002-02-19 at 14:59, David Trask wrote:
> Ok....I've been screwing around with this all day to no avail.  
> 
> I'm trying to NFS mount the home dir from another server.  
> 
> Here's the way my network is set up.....K12LTSP server (server.ltsp) eth0
> goes to LTSP network with IP address 10.0.0.254 (yes I edited all the
> necessary files)
> eth1 goes to building network and gets it's IP from DHCP (gateway is
> 192.168.0.1)
> 
> On RedHat server (penguin) with home dirs....eth0 goes to building network
> and gets it's IP from DHCP (gateway is 192.169.0.1)  I have the IP
> statically entered into the router (Freesco) as 192.168.0.14...so this box
> always gets the same IP address.
> 
> On RedHat server with home dirs I entered in /etc/exports a line which
> reads   /home       192.168.0.0/255.255.255.0 (rw)
> 
> On the K12LTSP server (server.ltsp) I entered   
> penguin:/home/		/home		nfs	defaults,rsize=8192,wsize=8192	0 0 
> into the /etc/fstab file
> 
> I then entered    192.168.0.14		penguin	penguin  into the /etc/hosts file
> on the K12LTSP server (server.ltsp)
> 
> I rebooted both machines and I get one of a couple messages
> 
> mount: RPC: Unable to recieve; errorno = Connection refused
> mount: RPC: timed out
> 
> 
> I can ping the Redhat server using the machine name (penguin) from the
> K12LTSP server, but I can't ping the K12LTSP server using the machine name
> (server or server.ltsp) from the Redhat server (penguin), I can ping
> however, with the IP address.
> 
> I know it's probably something stupid that I'm missing....can anyone help?
>  I'm willing to feel stupid if I can get this to work.
> 
> David N. Trask
> Technology Teacher/Coordinator
> Vassalboro Community School
> dtrask vcs u52 k12 me us
> (207)923-3100
> 
> 
> 
> _______________________________________________
> K12OSN mailing list
> K12OSN redhat com
> https://listman.redhat.com/mailman/listinfo/k12osn
> For more info see <http://www.k12os.org>
-- 
==========================================================
Paul Nelson................... pnelson riverdale k12 or us
Riverdale School, 11733 SW Breyman Ave, Portland, OR 97219
school (503)636-4511.....................fax (503)635-6342
Riverdale Web Page......... http://www.riverdale.k12.or.us





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]