[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] 3com ISA NIC Booting



James,

There were big changes between K12 1.1 and 2.0.  The biggest
change that I know if is that K12-2.0 is based on LTSP 3.0,
which was a major change for LTSP.

Indeed, the network drivers are compiled as modules on LTSP 3.0.

PCI network chipsets are automatically detected, but ISA chipsets
are not.

If you want to make it work with an ISA card, such as the 3c509, you
will need to pass both option-128 AND option-129.

For more information, take a look at this document:

  http://www.LTSP.org/instructions-3.0.html

Down near the bottom, you'll find important information for
configuring ISA network cards.

Jim McQuillan
jam Ltsp org




On Wed, 20 Feb 2002, James Jensen wrote:

> The problem booting a LT client with the 3com 3C509B-TPO ISA NIC is
> apparently not PC specific.
> 
> It appears that the tftp ROM floppy disk image is good but that it's choking
> when it's pulling over the kernel.  The message appears that while PCI cards
> are detected and automatically configured, ISA cards must be manually
> identified in the dhcpd.conf file.  I tried to do so with option-129 in that
> file without success.  I cannot get the ISA NIC to boot regardless of the PC
> that I put it in.
> 
> Again, this configuration was working under the K12LTSP 1.1 distro but not
> under 2.0.  I haven't determined the difference at this point but I did
> notice that in the kernel config file that ISA PNP is configured as a module
> and not compiled into the kernel, could this possibly be the
> difference/problem?
> 
> On another note with the Compaq Prolinea 466 (which makes a decent terminal
> when it works) using the 3com PCI 3C900-TPO NIC I needed to create a new ROM
> image from http://www.rom-o-matic.org/  enabling the following option to get
> it to remote boot:
> 
>     CONFIG_PCI_DIRECT (define this for PCI BIOSes that do not implement
> BIOS32 or not correctly)
> 
> Using this ROM image the client booted perfectly.
> 
> I know I'm not the only one out there using the previously mentioned 3com
> ISA NIC, anybody else got any ideas?
> 
> BTW, be sure to set the XSERVER option in lts.conf to XF86_SVGA if you are
> using the Cirrus Logic gd543x video chip.  It works great under K12LTSP 2.0
> without the need for a custom XF86CONFIG file (Yeeeeah!).
> 
> Thanks,
> 
> James
> 
> ----- Original Message -----
> From: "James Jensen" <jmsjnsn linuxfreemail com>
> To: <K12OSN redhat com>
> Sent: Tuesday, February 19, 2002 11:35 PM
> Subject: [K12OSN] 3com ISA NIC Booting
> 
> 
> > I had old Compaq Prolinea 466 PC's with 3com 3C509B-TPO booting fine with
> > the 3C509 floppy disk ROM under K12LTSP 1.1 but such is not the case with
> > K12LTSP 2.0.  It begins booting but then stops, telling me that the Kernel
> > cannot automatically configure the ISA NIC.  Will the "Kitchen Sink"
> kernel
> > resolve this or is there another option that I can use to fix this?
> >
> > I have a LOT of these 3C509B-TPO cards that can be used so I am hoping
> there
> > is a fix for this.
> >
> > Thanks,
> >
> > James Jensen
> > <><><><><><>
> > "Perilous to us all are the devices of an art deeper than we possess
> > ourselves.". -- JRR Tolkien
> >
> >
> >
> > _______________________________________________
> > K12OSN mailing list
> > K12OSN redhat com
> > https://listman.redhat.com/mailman/listinfo/k12osn
> > For more info see <http://www.k12os.org>
> 
> 
> 
> _______________________________________________
> K12OSN mailing list
> K12OSN redhat com
> https://listman.redhat.com/mailman/listinfo/k12osn
> For more info see <http://www.k12os.org>
> 





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]