[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[K12OSN] can't access internet from LTSP server



I have a stumper that I can't seem to get answered. I suspect this is more of a two-NIC network question than a LTSP or K12LTSP question.

I have been testing terminal services. I couldn't really get the actual LTSP working properly (something wrong with X on the client that I couldn't figure out,) so I downloaded and installed the K12LTSP version of Redhat7.2. It worked great right out of the box. My clients log right in and can utilize terminal services perfectly. However, on my normal installations of Redhat, I can assign a static IP to the linux PC and use my Win2K gateway to surf the internet. But when I install the LTSP'ized version with two NICs, I can ping the gateway, the gateway can ping the LTSP server, but I can't surf the internet. I think I've tried just about everything to try and use the gateway for internet access. If I can get the LTSP server on the internet via the gateway, then I believe the LTSP clients will fall into place, as well.

Some details.

My network "server" is actually a Win2k PC with internet connection sharing. I use VNC to virtually connect to the gateway to open and close dial in connections to the internet. I have to use win2k because I need an "internet answering machine" to answer the phone when I am online and there is no linux support for this type of product (living in the sticks, as I do, also makes separate lines very much cost prohibitive for dial in access to the internet.)

The terminal services PC has two NICs. ETH0 is attached to the terminal services clients via a 3com switch. ETH1 is attached via an additional switch to my network.

I might have a problem with the way the subnets are setup:

ETH0 is assigned by the K12LTSP default install to 192.168.0.254 and serves the LTSP clients .100 to .253.

ETH1 also gets its 192.168.0.x IP address either manually or through DHCP from the network. It doesn't matter if I manually assign the IP or let DHCP handle the IP asignment, but I have that if I let DHCP handle the assignment, I can't surf, so I just use 192.168.0.88. This may be because the DHCP services via Windows Internet COnnection Sharing aren't really full DHCP.

My win2k gateway PC is 192.168.0.1 and I always enter this address as the DNS server.

I tried to manually change the LTSP subnet on ETH0 to 192.168.1.254, etc., but I'm not sure this is the problem. Does the fact that the two subnets are using the same subnet scheme create the problem? I could see if the clients couldn't surf, then that may be the case, but the LTSP gateway can't surf.

After about 30 installs, different configurations, etc., I'm not sure where to go further with this issue. Can I provide some conf files that might give you an idea of where I need to go? Is this DNS or a route problem? Can the same IP adress scheme be used because the subnets are on different NICs, or is this the problem? Can you push me in the right direction of where to get some help? I looked through the archives but I didn't see anything similar to this problem.

Thanks for your help.



_________________________________________________________________
Chat with friends online, try MSN Messenger: http://messenger.msn.com





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]