[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] can't access internet from LTSP server



Thanks Mike...

I was reading your eamil and accidently typed webmin into the K12LTSP server's open Konqueror window, rather than the win2k PC, and suddenly I have internet access.

I'm not sure what's worse; not being able to figure out why the K12LTSP server didn't have internet access before, or not knowing how it suddenly does have access! It started working after I typed 'route -n' as you suggested. I don't think that fixed anything, but I had no access before typing that statement. My 'route -n' was pretty much like yours, except that I had two identical lines for the eth1 NIC. I suspect this was resolved after rebooting both the K12LTSP server and the win2k server this morning.

I am going to tempt fate and reload K12LTSP on the server to see if I can duplicate what I've done by following Arnel's advice and reading your email.

Thanks again for your thorough and enlightening response.

Pat


From: Mike Rambo <mrambo lsd k12 mi us>
Reply-To: k12osn redhat com
To: k12osn redhat com
Subject: Re: [K12OSN] can't access internet from LTSP server
Date: Wed, 03 Jul 2002 08:35:52 -0400

pat ring wrote:
>
> Thanks Jim...
>
> I'm afraid you are going to help me out with this a bit, if you, and others,
> don't mind.
>
> I'll need to change the subnet for the LTSP services, as the windows subnet
> isn't flexible. I know I can change the NIC assignment with something like
> Linuxconf. Changing ETH0 to 192.168.1.254 is no problem. However, I know
> that's not the only thing I need to do. Can you give me an idea of what
> else I need to modify for the ETH0 side?
>
> And I'm not sure how to set the default route to the win2k server. The
> route man page is greek to me.
>
> I apologize if this isn't the proper forum for 'linux for dummies.'
>
> Thanks again.


I'm sure many of us would be happy to help...

What does 'route -n' tell you. It should show something
like...

[mrambo linuxts1 k12ltsp2.1.0-templates]$ /sbin/route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric
Ref    Use Iface
192.168.3.0     0.0.0.0         255.255.255.0   U     0
0        0 eth1
10.8.24.0       0.0.0.0         255.255.248.0   U     0
0        0 eth0
127.0.0.0       0.0.0.0         255.0.0.0       U     0
0        0 lo
0.0.0.0         10.8.24.1       0.0.0.0         UG    0
0        0 eth0

You'll note both server network cards and the networks to
which they're attached on the top two lines - your actual
numbers will likely be different of course. The third line
shows the localhost network. The bottom line is the default
gateway (looked at from the perspective of the LTSP server -
not the client workstations) and the interface to which it
is attached. This item affects whether the ltsp server
itself will find the web gateway.

IIRC, you said that eth1 was on the same network at your w2k
gateway box and your w2k box was at 192.168.0.1. You should
have the following two lines in /etc/sysconfig/network...

GATEWAY=192.168.0.1
GATEWAYDEV=eth1

Do a '/sbin/service network restart' if you make changes to
this file to get them to take effect.

While linuxconf will probably work if you need to change
your IP addresses I'd recommend you give webmin a try from a
web browser (if it's on your system - if not google for
webmin). Maybe it's my imagination but it seems webmin
doesn't screw as many things up as linuxconf can. Also, it
probably just as easy to just edit the files in
/etc/sysconfig/network-scripts. Look at ifcfg-eth0 and
ifcfg-eth1. Here are examples of what a static and dhcp
config look like. BTW, I'd think you would want both IP
addresses hard coded on your ltsp server so you don't have
to do script magic in the background to account for IP
address lease changes on one of your network cards.

[root mrambo mrambo]# more
/etc/sysconfig/network-scripts/ifcfg-eth0
DEVICE=eth0
BOOTPROTO=static
IPADDR=192.168.3.12
NETMASK=255.255.255.0
NETWORK=192.168.3.0
BROADCAST=192.168.3.255
ONBOOT=yes

[root mrambo mrambo]# more
/etc/sysconfig/network-scripts/ifcfg-eth1
DEVICE=eth1
BOOTPROTO=dhcp
ONBOOT=yes

Once again, if you make changes in either of these files you
can '/sbin/service network restart' to get them to take
effect.

If you've changed the /etc/rc.d/init.d/nat file you need to
'sbin/service nat restart' too. Of course a server reboot
will do the same thing.

To check that nat is doing it's thing you can
'/sbin/ipchains -L -n' and check the forward chain at the
bottom. You should see something like...

Chain forward (policy ACCEPT):
target     prot opt     source
destination           ports
MASQ       all  ------  192.168.3.0/24
0.0.0.0/0             n/a

The above item will affect whether the ltsp workstations
route to the web through your ltsp server and then the w2k
gateway.

BTW (HEADS UP!! K12LTSP team), it seems like /etc/named.conf
and the zone files in /var/named (ltsp.arpa & ltsp.zone)
should be added to the list of files at
http://k12ltsp.org/install.html that need modification if
you change the ltsp network IP address scheme - at least for
version 2.1.0 anyway. Also, FWIW, I'm not certain that it
fixed anything as I've forgotten why I did the fix, but when
I was problem solving during our setup I also modified the
default server setting in /opt/ltsp/i386/etc/rc.local,
rc.setupx, and rc.setupx3 too.

Hope this is helpful and isn't too much too fast...

Yell if you have questions.


-- Mike Rambo mrambo lsd k12 mi us

> >
> >On Tue, 2 Jul 2002, pat ring wrote:
> >
> > >
> > > ETH0 is assigned by the K12LTSP default install to 192.168.0.254 and
> >serves
> > > the LTSP clients .100 to .253.
> > >
> > > ETH1 also gets its 192.168.0.x IP address either manually or through
> >DHCP
> > > from the network. It doesn't matter if I manually assign the IP or let
> >DHCP
> > > handle the IP asignment, but I have that if I let DHCP handle the
> > > assignment, I can't surf, so I just use 192.168.0.88. This may be
> >because
> > > the DHCP services via Windows Internet COnnection Sharing aren't really
> >full
> > > DHCP.
> > >
> > > My win2k gateway PC is 192.168.0.1 and I always enter this address as
> >the
> > > DNS server.
> > >




_______________________________________________
K12OSN mailing list
K12OSN redhat com
https://listman.redhat.com/mailman/listinfo/k12osn
For more info see <http://www.k12os.org>




_________________________________________________________________
Chat with friends online, try MSN Messenger: http://messenger.msn.com





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]