[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] can't access internet from LTSP server: resolved

Hi Mike...Eureka!

I reloaded K12LTSP, modified the files listed in the install page as Arnel suggested, then reread your email and followed your troubleshooting steps. I think modifying the /etc/sysconfig/network-scripts/icfg-eth0 rather than going through linuxconf is what fixed this for me. The BROADCAST line was invalid, not reflecting the change from to In addition, your services restart actually allowed me to see what wasn't working once linux tried to shut those services or devices down and restart. Had a scare with XFS from the clients, but completely rebooting the K12LTSP server did the trick. As I'm a glutton for punishment, I changed networks to match your configuration, 192.168.3.x for eth0, just to see if I could do it again and it worked fine after making all of the changes and rebooting.

Thanks again for your help.


From: Mike Rambo <mrambo lsd k12 mi us>
Reply-To: k12osn redhat com
To: k12osn redhat com
Subject: Re: [K12OSN] can't access internet from LTSP server
Date: Wed, 03 Jul 2002 08:35:52 -0400

pat ring wrote:
> Thanks Jim...
> I'm afraid you are going to help me out with this a bit, if you, and others,
> don't mind.
> I'll need to change the subnet for the LTSP services, as the windows subnet
> isn't flexible. I know I can change the NIC assignment with something like
> Linuxconf. Changing ETH0 to is no problem. However, I know
> that's not the only thing I need to do. Can you give me an idea of what
> else I need to modify for the ETH0 side?
> And I'm not sure how to set the default route to the win2k server. The
> route man page is greek to me.
> I apologize if this isn't the proper forum for 'linux for dummies.'
> Thanks again.

I'm sure many of us would be happy to help...

What does 'route -n' tell you. It should show something

[mrambo linuxts1 k12ltsp2.1.0-templates]$ /sbin/route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric
Ref    Use Iface   U     0
0        0 eth1   U     0
0        0 eth0       U     0
0        0 lo         UG    0
0        0 eth0

You'll note both server network cards and the networks to
which they're attached on the top two lines - your actual
numbers will likely be different of course. The third line
shows the localhost network. The bottom line is the default
gateway (looked at from the perspective of the LTSP server -
not the client workstations) and the interface to which it
is attached. This item affects whether the ltsp server
itself will find the web gateway.

IIRC, you said that eth1 was on the same network at your w2k
gateway box and your w2k box was at You should
have the following two lines in /etc/sysconfig/network...


Do a '/sbin/service network restart' if you make changes to
this file to get them to take effect.

While linuxconf will probably work if you need to change
your IP addresses I'd recommend you give webmin a try from a
web browser (if it's on your system - if not google for
webmin). Maybe it's my imagination but it seems webmin
doesn't screw as many things up as linuxconf can. Also, it
probably just as easy to just edit the files in
/etc/sysconfig/network-scripts. Look at ifcfg-eth0 and
ifcfg-eth1. Here are examples of what a static and dhcp
config look like. BTW, I'd think you would want both IP
addresses hard coded on your ltsp server so you don't have
to do script magic in the background to account for IP
address lease changes on one of your network cards.

[root mrambo mrambo]# more

[root mrambo mrambo]# more

Once again, if you make changes in either of these files you
can '/sbin/service network restart' to get them to take

If you've changed the /etc/rc.d/init.d/nat file you need to
'sbin/service nat restart' too. Of course a server reboot
will do the same thing.

To check that nat is doing it's thing you can
'/sbin/ipchains -L -n' and check the forward chain at the
bottom. You should see something like...

Chain forward (policy ACCEPT):
target     prot opt     source
destination           ports
MASQ       all  ------             n/a

The above item will affect whether the ltsp workstations
route to the web through your ltsp server and then the w2k

BTW (HEADS UP!! K12LTSP team), it seems like /etc/named.conf
and the zone files in /var/named (ltsp.arpa & ltsp.zone)
should be added to the list of files at
http://k12ltsp.org/install.html that need modification if
you change the ltsp network IP address scheme - at least for
version 2.1.0 anyway. Also, FWIW, I'm not certain that it
fixed anything as I've forgotten why I did the fix, but when
I was problem solving during our setup I also modified the
default server setting in /opt/ltsp/i386/etc/rc.local,
rc.setupx, and rc.setupx3 too.

Hope this is helpful and isn't too much too fast...

Yell if you have questions.

-- Mike Rambo mrambo lsd k12 mi us

> >
> >On Tue, 2 Jul 2002, pat ring wrote:
> >
> > >
> > > ETH0 is assigned by the K12LTSP default install to and
> >serves
> > > the LTSP clients .100 to .253.
> > >
> > > ETH1 also gets its 192.168.0.x IP address either manually or through
> > > from the network. It doesn't matter if I manually assign the IP or let
> > > handle the IP asignment, but I have that if I let DHCP handle the
> > > assignment, I can't surf, so I just use This may be
> >because
> > > the DHCP services via Windows Internet COnnection Sharing aren't really
> >full
> > > DHCP.
> > >
> > > My win2k gateway PC is and I always enter this address as
> >the
> > > DNS server.
> > >

K12OSN mailing list
K12OSN redhat com
For more info see <http://www.k12os.org>

Join the world?s largest e-mail service with MSN Hotmail. http://www.hotmail.com

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]