[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] C Spot run...



Tony,

As I understand it :-), in general, to avoid [most of the time] what you are going through, try to find the RPM (Redhat Package Manager) file - key word here - PACKAGE. Albeit a different paradigm than Windows...but a package of files bundled together to make a [again, most of the time] complete installation.

If you can't find the RPM, then you are indeed experiencing the problems associated with the somewhat immature nature of a 30 some year old operating system's legacy ('nix). It is still very much a techno-geek environment to run, and one of the primary reasons that LINUX is not ready for the desktop. LTSP puts control of the environment back into the "data center", which is a viable way to run it today.

Working with my blazing high speed 26.4k dialup connection, searching around, and subscribing for a bunch of updates is just not feasible, so I always look for the RPM.

It'll get there, and sooner than many think :-)
Kirk

At 12:02 PM 7/7/2002, you wrote:
I'm in disbelief...
And, kind of exasperated.
I downloaded several applications (Scribus, as discussed earlier and Gaby, a small database program, couple others) and have tried to install them to no avail.
I've been working on this all weekend.
Wanna know why? Because apparently there is no C compiler on my machine.
Now, I installed all the devtools that came with the CD set. I am just boggled that gcc or something isn't here. I went back into the CD set looking to see if I had somehow missed it on install, but nope, not there.
So, I have downloaded gcc and tried to install it. It required 3 additional libraries, which I have since located and downloaded. Not installed, however, as the glibc-devel libraries ared asking for old kernel headers, which I can't install because I have a newer kernel...
I tried both older and newer versions of the glibc-devel, nope.
Appears as though I have hit a brick wall. I can't install any programs written in C or C++...this is crazy!
I'm lost here....Shouldn't I be able to compile programs written in C and C++ without all this hassle? Why wasn't a C compiler included in the devtools?
Why is it appreantly impossible to install gcc now? Is it me?
What to do now?!


Tony


http://www.School-Library.net
Read, Connect, Learn!
_____________________________________________________________
Promote your group and strengthen ties to your members with email yourgroup org by Everyone.net http://www.everyone.net/?btn=tag




_______________________________________________
K12OSN mailing list
K12OSN redhat com
https://listman.redhat.com/mailman/listinfo/k12osn
For more info see <http://www.k12os.org>





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]