[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] amusing, for sure



Anthony-

Welcome to the blackhole of linux distro compatibility and library dependencies ;-) First, the reason that gcc wasn't installed is probably because the development tools checkbox was not checked upon install. (this will teach you to install those tools no matter what kind of installation you are doing, I found out the hard way too). I found out when trying to upgrade to a newer version of gcc, just how many dependencies it has. When you forced your install of gcc from another distro (apparently, its not a compatible one.. plus RedHat has their own version of gcc anyways) you probably broke many, many dependencies. You might try using APT-RPM (just a suggestion mind you, I haven't tried it) to check to see if there are any obvious missing or damaged packages. If you can, also uninstall any of the non-redhat packages that you installed, then install the redhat version. Other than that, backup all your config files that you have modified, and re-install.

So the moral is, unless the package was compiled and packed with RH compatibility in mind, don't install it, unless you know exactly what is going to happen to your system. If you can't find an rpm version of the program you want (very unlikely for any version of RH), don't be afraid to download the tarball and:

tar zxvf foobar.tar.gz
cd foobar
less README
./configure
make
make install

It can't do that much damage (definately not as much as forcing an rpm), and it also makes you feel more like a *nix admin of old ;-)

Hope this help,

Jesse



From: anthony baldwin <mrbaldwin school-library net>
Reply-To: k12osn redhat com
To: k12osn redhat com
Subject: [K12OSN] amusing, for sure
Date: Tue, 9 Jul 2002 20:50:05 -0700 (PDT)

Well,
I think you'll get a kick out of this one...
Since I couldn't seem to get the gcc installed, which I needed for the installation of some other software, I decided to take matters into my own hands.
So, I found the devtools cd I had lying around for another distro (blue Linux, Matt Jezorek, Caldera/Redmond hybrid) and forced the installation of the disc.
And, it successfully installed the gcc, which allowed me to install Scribus. Nonetheless, Scribus won't open. I get a "segmentation fault" error.
Now, it gets even better.
As result, whether directly or indirectly I cannot confirm, of forcing the other distros devtools, I seem to have disrupted parts of the system.
The package manager won't upon at all.
I also can't get the RH cd's to autorun.
I seem to keep running into this:
"error while loading shared libraries
libpopt.so.0 : cannot open shared object file: no such file or directory"
And, indeed, I can find no such file or directory as libpopt.so.0 anywhere, including on the cd set that this OS came on. I am wondering if this particular file belongs to the other distro, but my system is now looking for it becuase I screwed it up.
I can boot up, log in and perform the majority of functions, but installing rpms seems to have been rendered an impossiblity, which is not good.
I tried to "repair" the system by placing the OS cd in and "upgrading" (no repair optino present) to no avail. It keeps sending me back to reboot, saying that parts of th filesystem were not shutdown lceanly, or seom such thing, regardless of how many times I reboot, shutdown or otherwise attempt to perform this function.
So, I wonder if there is a way to repair this, beyond hunting down everything I forced in and deleting it, which I would find impossible. Or if there is some file I can simply edit in the configuration of the system..or I I ahve to go to a complete re-install to regain former functionality.
If that is a requirement (reinstall) I may just as well order the new cd set, I suppose. Really, if I can upgrade with the cd set without disrupting my present configurations (erroneous ones aside) that would satisfy me.
I have given a bit of work to the configuration of this system and added a number of programs, all of which I have been pretty happy with, so I really don't want to have to start from scratch again. I suppose it is all a great learning process. In the meantime, my Windows98se partition is still functional (well, functioning under normal windows parameters, anyway), so I have not disrupted my life significantly by crippling my linux partition. All the same, I was feeling pretty close to being windows free...maybe this is just one more step in the learning process that will get me there?
Oddly enough, as I was trying to repair the system, I discovered that gcc-v.2.96 IS on the first disc of my set. I don't understand why it was not installed initially. Would have saved me a lot of trouble.
When you are finished laughing I would appreciate any suggestions.


Tony

http://www.School-Library.net
Read, Connect, Learn!



_____________________________________________________________
Promote your group and strengthen ties to your members with email yourgroup org by Everyone.net http://www.everyone.net/?btn=tag




_______________________________________________
K12OSN mailing list
K12OSN redhat com
https://listman.redhat.com/mailman/listinfo/k12osn
For more info see <http://www.k12os.org>




_________________________________________________________________
Send and receive Hotmail on your mobile device: http://mobile.msn.com





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]