[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] Dual Boot Question



Aaron Leininger wrote:

I am setting up a stand-alone dual boot client for a teacher in my school.
She wanted to compare 2 distributions in a dual-boot environment. I have
SuSe set up on dual boot with windows 98 (what she currently runs in her
lab) on 1 box using the LILO boot loader. That box works fine for either OS.
I have another box(identical hardware) with Redhat 7.3 and Windows 98. When
I did the redhat side of the install, I chose Grub for bootloader and to
install it to the MBR (That's what worked on the SuSe box) and to make
redhat the default partition. My problem is that somehow the bootloader
didn't get installed right. The box boots up directly to Windows with no
Bootloader prompt unless I use a bootdisk or CD. Can anyone give me some
ideas on how to fix this? Please bear in mind that I am not an expert at
Linux...especially with stuff like this. I would be willing to reinstall
redhat again with LILO except that due to a small hard disk, I am tight on
space and I spent a long time going through packages to get in under my
limit and I don't want to go through that again if I can help it.

Here's what I've tried so far... 1) booted off of CD into rescue mode. followed instructions to mount current
system. that part worked. When I went to edit grub.conf, I found that it was
a symbolic link to the /boot folder where the real file was...except that
there was no grub.conf file in the /boot folder.


2) reran install program thinking I could choose update mode and change
bootloader to LILO. I did so and because I had not "out of date" packages as
far as the installer was concerned, it wouldn't rewrite my bootloader.


I would appcreciate any ideas.

Thanks,
Aaron

I had the same problem when installing redhat7.3 and grub, What I did
was check the /etc/anaconda generated lilo,conf and see if Linux and Windows
is set up properly in lilo and then i Rename the file as /etc/lilo.conf
and then I did SU and /sbin/lilo -v and it reloaded the MBR and booted properly.
I do believe there's a bug in Grub and rh7.3. LOL


Jim tate





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]