[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] Xvesa problems [fixed?]



On Thu, 18 Jul 2002, Daniel Loomis wrote:

>Like Chris Rears, I had trouble getting Xvesa to work with the new 2.4.18-ltsp 
>kernels on ThinkNIC terminals.  Using the original LTSP-2.1.0 distribution, 
>which uses kernel 2.4.18 for the server and 2.4.9 for the terminals, Xvesa 
>worked just fine.  When I upgraded the system to the newer 2.4.18 kernels 
>Xvesa no longer worked.  It gave the alternating gray screen / blue screen 
>with the mouse X in the middle that Chris described.  
>
>The only remedy so far has been to change the XSERVER=Xvesa to XSERVER=auto.  
>That, of course, resulted in somewhat less video quality with periodic scan 
>streaks on the terminals.  I have not been able to us USE_XFS=Y with 
>ThinkNICs under XFree86-4.
>
>Has anyone looked at updating the Xvesa driver to work with kernel 2.4.18?

Hey Dan,

While I was out-and-about today, I swung by Chris's shop (he's just a couple
miles down the road ;-). 

I reverted the terminal's kernel back to 2.4.9 and it still wouldn't run
the Xvesa server. I ran out of time before I chance to dig any further.

Now that I have a minute to look through the code, this looks like a bug
in the latest version of the core LTSP package.

I'll fire off a patch to Jim.

Here's a revised package for K12LTSP:

   ftp://k12linux.mesd.k12.or.us/pub/distributions/testing/2.1.1/ltsp_core-3.0-13.i386.rpm

Please let me know if this fixes the problem!

-Eric





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]