[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

RE: [K12OSN] Special logins..........



On Wed, 5 Jun 2002, Bert Rolston wrote:

> Hi Russ,
> >   ps afx | grep gdm

> 12926 pts/1	S	0:00	\_ grep gdm

yeah -- it is not running -- a neat shell scripting trick is
to run:

   ps afx | grep [g]dm

Question for the pupil: Why is the output different?

> > presentation I used as a presentation outline 18 months agos 
> > is at: 
> >   http://www.colug.net/notes/0012mtg/COLUG-0012.html
> 
> Thanks. I was getting crossed eyed. Slowly looking through it again has helped.

Yeah -- but did you bake me cookies?  (I've trained from that 
outline as well)

> Soon I'll be able to create login scripts for Linux, as well
> as netware, NT, and DOS stuff.
> 
> I take it I can run gdmconfig from KDE and the Win login will work.

Well, if present, you can run it, but we need to get gdm as
your login manager for the changes you make to become useful
<grin> -- I believe you will find the gdm _package_ is not yet 
installed on your server.  A quick trip to your install CD's 
of friendly local FTP mirror can remedy that (there are 
probably lots of dependencies as well.  Let's see:

[herrold oldnews herrold]$ rpm -q --requires gdm | sort -u
/bin/bash
/bin/sh
/etc/pam.d/system-auth
/etc/X11/xdm/Xsession
gnome-libs >= 1.2.13
ld-linux.so.2
libart_lgpl.so.2
libaudiofile.so.0
libc.so.6
libc.so.6(GLIBC_2.0)
libc.so.6(GLIBC_2.1)
libc.so.6(GLIBC_2.1.3)
libdb.so.2
libdl.so.2
libesd.so.0
libgdk-1.2.so.0
libgdk_imlib.so.1
libgdk_pixbuf.so.2
libglade-gnome.so.0
libglade.so.0
libglib-1.2.so.0
libgmodule-1.2.so.0
libgnome.so.32
libgnomesupport.so.0
libgnomeui.so.32
libgtk-1.2.so.0
libICE.so.6
libm.so.6
libm.so.6(GLIBC_2.0)
libnsl.so.1
libnsl.so.1(GLIBC_2.0)
libpam.so.0
libSM.so.6
libX11.so.6
libXext.so.6
libXi.so.6
libxml.so.1
libz.so.1
pam >= 0.68
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
/sbin/nologin
usermode
/usr/bin/scrollkeeper-update
/usr/sbin/useradd
xinitrc
xsri >= 2.0.2
[herrold oldnews herrold]$

... grurgggg ...  Find the CD's.

gdm is, according to its PR, a ground up re-write of xdm (the
hoary ancestor in the base X consortium release)

-- It is quite worth the payback to install the 'gdm' package:

[herrold oldnews herrold]$ rpm -qf `which gdm`
gdm-2.2.3.1-20
[herrold oldnews herrold]$ rpm -ql gdm | grep bin
/usr/bin/gdm
/usr/bin/gdmchooser
/usr/bin/gdmconfig
/usr/bin/gdmlogin
/usr/bin/gdmphotosetup
/usr/sbin/gdm-restart
/usr/sbin/gdm-safe-restart
/usr/sbin/gdmconfig
[herrold oldnews herrold]$

and use it -- it is 'free-er' and frankly, better.

-- Russ





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]