[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] gray screen in X



Yes - thanks to both Keith, Bert, Adam, and others who
helped along the way. I went down the mouse path for a short
period of time as one of the messages displayed when the X
server started was about the mouse. In my case though, I
didn't realize that the server itself had to be booted up
init 5 - I was using init 3 as I do for most servers.
http://www.ltsp.org has this exact problem listed in the
troubleshooting section of their docs. They go on in detail
about what you should see with 'netstat -ap | grep xdm' and
all but never directly said what was wrong if netstat showed
nothing (which is what I had). I finally reread the message
Adam sent me earlier in this process and suddenly the light
went on and it all made sense. The bottom line is that
netstat should show the display manager running (gdm or
kdm). That is dependant upon the server being started init
5.

I restarted the server init 5 - problem solved!


Thanks to all who helped.



Turner wrote:
> 
> Hi Mike
> 
> I would agree with Bert comments.  Check to see if the mouse on the work
> station is at "Com 1" or "Com 2" sorry to use the windoze term.  You may
> need to change to /dev/ttyS1 for that machine in the lts.conf file
> 
> I can't find where you said what machines you are using as work
> stations.  In my case it is a real mixture of specifications and cards.
> For 486's and other older machines (especially those with ISA Network
> Cards) but even with pentiums I have found it easier to set each up
> individually with a fixed IP address in the dhcpd.conf file and the then
> use the workstation name specifed in this file to individually setup the
> X-configuration in the its.conf file.  I prominently label each machine
> so I remember what the workstation name I have given it.  I also write
> the MAC address on the outside face of the network card.  This makes it
> easy to individually tweak a particular machine, rather than rely on the
> default settings.  Many of my older machine use the old VGA, SVA and
> VESA settings in X and most need to be set for RAM and resolution.  Both
> files have good examples and the documentation on the K12LTSP and the
> LTSP website is great.
> You are probably already doing things like this so forgive me if "I am
> trying to teach my grandmother to suck eggs" so as to speak.
> 
> Keith & Chris Turner
> 167 Innes Rd
> St Albans
> Christchurch 8005
> New Zealand
> ph  64-3-355-8908
> email turner cyberxpress co nz
> 
> -----Original Message-----
> From: k12osn-admin redhat com [mailto:k12osn-admin redhat com] On Behalf
> Of Bert Rolston
> Sent: Friday, June 14, 2002 9:06 AM
> To: 'k12osn redhat com'
> Subject: RE: [K12OSN] gray screen in X
> 
> Hi mike,
> 
> Bert here.
> 
> >
> > I've tried both ways - no difference. I have also, since I
> > am really just starting to experiment with LTSP, retrieved
> > version 2.1.0 of K12LTSP and installed that on the server (I
> > had been using v2.0.2 - and before that LTSP direct from the
> > LTSP project - that I did have working).  I have adjusted
> > all the files listed on the installation webpage to fit our
> > networks and conventions. The dhcpd.conf file is the same
> > one I used when I first tried using LTSP direct from the
> > LTSP project (before I discovered K12LTSP). It worked there
> > and I assume should work now.
> 
> I'm using K12LTSP v2.0 without any problems. I haven't modified the
> DHCPD
> files.
> 
> > But I still have the same problem. ..............<SNIP>
> 
> > If it makes any difference I can ping the LTSP server (or
> > anywhere else on our WAN) from the workstation so it would
> > appear communications are working.
> 
> Communications are working. The problem isn't with DHCP or TCP/IP
> 
> > On the subject of DNS, what should nslookup reveal on both
> > the server and workstation? ..........<SNIP>
> 
> This is a red herring, it ties in with DHCP.
> 
> > Finally, this is found in the server log (manually wrapped
> > in an effort toward readability).
> >
> > Jun 13 08:10:27 linuxts1 dhcpd: DHCPDISCOVER from
> >               00:e0:b8:18:64:15 via eth1
> 
> DHCP has recognised the MAC address of the terminal NIC
> 
> > Jun 13 08:10:27 linuxts1 dhcpd: DHCPOFFER on 192.168.3.152
> >               to 00:e0:b8:18:64:15 via eth1
> 
> IP address is assigned to the terminal NIC
> 
> > Jun 13 08:10:29 linuxts1 dhcpd: DHCPREQUEST
> >               for 192.168.3.152 (192.168.3.1)
> >               from 00:e0:b8:18:64:15 via eth1
> 
> Terminal makes a request to server (bootstrap I think)
> 
> > Jun 13 08:10:29 linuxts1 dhcpd: DHCPACK on 192.168.3.152
> >               to 00:e0:b8:18:64:15 via eth1
> 
> Server acknowledges request from terminal
> 
> > Jun 13 08:10:30 linuxts1 rpc.mountd: authenticated mount
> <SNIP>
> > Jun 13 08:10:36 ltws002 init: Switching to runlevel: 5
> 
> The kernel loads and the X server attempts to start for that terminal
> session.
> 
> The grey screen is related to the X server NOT dhcp.
> 
> I have found the following causes for this.
>         - Incorrect mouse type specified. Beware of typos for serial
> mouse, it is
> /dev/ttyS0 where 0="zero". Also note that mouse
> protocol can cause
> this.
>         - Incorrect Xserver specified. The Xserver specifies the
> resolution and
> refresh ratres for the card.
> 
> Hope this helps,
> Bert
> 


-- 
Mike Rambo
mrambo lsd k12 mi us





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]