[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] smbmount share into root filesystem/permissions error



I have had the same issue.  There is someone on here that is using AR liek
this, but I haven't gotten them to reply to me on how they got it done.
Mine is a Novell mount onto my LTSP but it is the same issue.  I haven't
gotten too much time to sit and work on it though so I don't have any
great info on it yet.  If you find something out please post it and I will
do the same.

Brent Norris (http://brentnorris.net)
Assistant Technology Coordinator, Edmonson County Schools
H: 270.563.9226

On 31 Oct 2002, Barry Smoke wrote:

>  This is a samba/smbmount/ltsp question/problem...and it is kind of
>  detailed....I tried to simplify as much as possible...:
>  if anyone can help, we would be grateful!
>
>  We have a share, that contains our alsdata for Accelerated Reader(AR).
>  This is working great for Accelerated Reader, and has been for 1 year
>  now.  We force the alsdata share to have these permissions in the
>  smb.conf file:
>  [alsdata]
>          path = /raid/bes/apps/alsdata
>          admin users = @tech @library
>          valid users = @tech @bes @library
>          force group = bes
>          force user = bes
>          force create mode = 0777
>          force directory mode = 0777
>          comment = Renaissance Learning Data Folder
>          write list = @bes
>          browseable = yes
>          oplocks = yes
>          blocking locks = yes
>          level2 oplocks = no
>          fake oplocks = no
>          oplock contention limit = 150
>          veto oplock files
>  =/arcerttb.*/arclass.*/arenroll.*/argoaltb.*/arhtsqiz.*/arriquiz.*/arrpquiz.*/arstu.*/repsttng.*/ripubsi.*/sndmatch.*/student.*/cfg.*/arqbrtb.*/arptstb.*/alsbigc.*/
>           vfs object = /usr/lib/samba/vfs/recycle.so
>          vfs options = /etc/samba/recycle.conf
>
>  so we force the alsdata share to be wide open, which is what AR needs it
>  to be, and this is also the case with novell, etc...
>
>  now to what is not working...
>
>  We have started experimenting with AR, and codeweavers crossover office:
>  so, now that AR installs correctly onto a linux box with crossover
>  office installed, we now have the need to mount this alsdata share into
>  the root filesystem.
>
>  We are using "mount -t smbfs -o
>  username=bes,password=******,dmask=0777,fmask=0777 //samba/alsdata
>  /alsdata"
>
>  we also tried setting a uid, and gid to bes, and the same results below:
>
>  what happens on our ltsp box, is that when you log on to a ltsp session
>  as root, and run AR in a wine session(crossover office installed)
>  the AR program works correctly...
>
>  BUT......
>
>  when you log on as any other user added to the ltsp server,
>  there is a database error in AR....which we have seen before, and was a
>  permissions based error....why would it work for root on ltsp, and not
>  for any other user
>
>
>
>
>
>
> _______________________________________________
> K12OSN mailing list
> K12OSN redhat com
> https://listman.redhat.com/mailman/listinfo/k12osn
> For more info see <http://www.k12os.org>
>





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]