[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

RE: [K12OSN] progressive patch/linux progress patch/gui boot/SoClose!!



I never saw a reply to this post by Barry. Did anyone come up with
anything? I haven't any experience with the progressive patch but will
be playing with it soon to see what I can do.

Caleb Wagnon, MCP
Fordyce School District
Office of Technology
Fordyce, Arkansas 71742
(870) 352-2968

-----Original Message-----
From: k12osn-admin redhat com [mailto:k12osn-admin redhat com] On Behalf
Of Barry Smoke
Sent: Friday, November 01, 2002 4:28 PM
To: k12osn redhat com
Subject: Re: [K12OSN] progressive patch/linux progress patch/gui
boot/SoClose!!

linux progress patch hides the boot messages and makes the boot process
more like windows(starting windows bitmap, with scroling blue bar)
check here:
http://lpp.freelords.org/About.phtml
http://lpp.freelords.org/
and here are themes:
http://lpp-themes.sourceforge.net/

This is very useful, and has been implemented on ltsp(as you saw on the
customkernel link below, and check here:
http://www.ltsp.org/instructions-2.09pre4.html

now I had to do this to make the instructions work without an error
message:
cp /usr/lib/mknbi/first32 0x92800 linux /usr/local/lib/mknbi/

and Tait had already downloaded the newer version of mknbi_1.2-5.tar.gz
because straight 1.2 crashed...

now, I am to the point that I have a kernel compiled for ltsp from the
above instructions, and can not get it to boot with k12ltsp.  I am sure
it is my understanding of the ltsp/pxe boot process that is lacking....
or there is something wrong with the instructions(lacking for k12ltsp?)

Here is the steps so far:
downloaded everything, from instructions from link below:(kernel
sources,mknbi,ltsp_initrd_kit-3.0.4-i386.tgz, lpp patch)

patched kernel, then copied ltsp_initrd_kit kernel config file to
.config

ran make xconfig
turned on linux progress patch in console drivers
turned on virtual framebuffer as stated in how-to
compiled(make dep&&make -j3 bzImage&& make modules&& make
modules_install)

now have a bzImage file in /usr/src/linux-2.4.18-ltsp/arch/i386/boot

ran buildk
it created a vmlinuz-2.4.18 (which the how-to says to use)
but it also created an initrd.ltsp(old one is initrd.lts in current
default)

I have tried copying the vmlinuz-2.4.18 to /tftpboot/lts/pxe, and
editing the /tftpboot/lts/pxe/pxelinux.cfg/default
to 
label linux
  kernel vmlinuz-2.4.18
  append root=/dev/ram0 rw init=/linuxrc initrd=initrd.ltsp vga=quiet

NOTE***
I have tried with the initrd.ltsp file and without

Results as follows:

when I reference the vmlinuz-2.4.18 file created with the
ltsp_initrd_kit at all(with or without the initrd entry) it gives an
error

when I copy the bzImage file directly from my compiled source tree, and
reference the initrd created with the kit, I get closer, but it can't
find the modules, which I assume is the ramdisk not working properly...
is the initrd kit not working properly?

Any ideas?
Have I missed any steps?
Why would the kernel I compiled boot(no lpp gui by the way when it does)
but then freeze at modules, yet the one created with initrd kit not work
at all?
All help appreciated!

Barry Smoke
District Network Admin
Bryant Public Schools
Bryant, AR



---
Outgoing mail is certified Virus Free.
Checked by AVG anti-virus system (http://www.grisoft.com).
Version: 6.0.410 / Virus Database: 231 - Release Date: 10/31/2002
 





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]