[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] TeacherTool.py Help debugging



thanks for the hint!

I tried the netstat line from line 279 and then counted line parts

for linepart for lines 287 and 288 change them to read as below

line 287    machine = lineParts[6]
line 288    user = lineParts[10]

trelf13 yahoo com wrote:

I'm wondering if maybe one of the commands like
netstat responds differently on a different system.
This was written on/for RedHat 7.3 I believe with
python2.  Is everyone here using k12ltsp off redhat
7.3?

If someone would send me some screenshots of the
problem(s) and what you're running on, I'd be more
than willing to take a look at it tomorrow in school.

Donald

--- Tim Litwiller <tim litwiller net> wrote:


so your saying it's display needs to be on another
display than the server for it to work?


I get x11 33913 type or items in the "user" list
and ps errors in the terminal window, so I tried
ps x11 33913 and then I get a list of the programs
running as that item, it looks like it is not finding the username
but something else.


and if I run it like you suggest it does show ssh 33913 instead of x11 33913 also I still get the ps errors when trying to view a
users processes and skill errors when trying to logout a user.


I believe that it is not passing or maybe even
getting usernames correctly.



Jeffrey Elkner wrote:



I'm cc'ing this to Robert Melton, who wrote


TeacherTool.py, in the hopes


that he can better answer you question than I can.

We put TeacherTool.py on our LTSPserver in the


/root directory. I then


ssh into the LTSPserver from my desktop box, su -


to root and run


./TeacherTool.py &

A Tkinter window then appears on *my* desktop that


looks like the


attached image below.

The X display has to be exported so that it can run


on the server and


display on my box. I think your present error has


something to do with


that.

I'm also cc'ing this to Donald Oellerich, the


student who administers


our LTSPserver. If Robert doesn't have time to


answer, perhaps Donald


can.

Hope this helps.

jeff elkner
yorktown high school
arlington, va

On Mon, 2003-01-06 at 17:19, David Trask wrote:




I modified the code to read

names = names+"\n"+x

As I have Python 1.5.2 as it comes with K12LTSP


2.1 I can get the GUI to


start....but all I can see in the list are a bunch


of "X11 32777" and so


forth. I can't make heads or tails of it. Any


ideas?


k12osn redhat com writes:




David Trask wrote:




Hi,

I copied the TeacherTool.py script from the


Yorktown High LUG site

http://yhslug.tux.org/projects.php3

When I tried to run it I got the following


error......can anyone


straighten me out?


[root server root]# python TeacherTool.py




Run it as:

python2 TeacherTool.py

and preferably as non-root, unless it requires to


be run as root.

You also need python2 installed.

Regards,
--
Konstantin ("Icon") Riabitsev
Duke University Physics Sysadmin
www.phy.duke.edu/~icon/pubkey.asc




David N. Trask
Technology Teacher/Coordinator
Vassalboro Community School
dtrask vcs u52 k12 me us
(207)923-3100






------------------------------------------------------------------------




_______________________________________________
K12OSN mailing list
K12OSN redhat com
https://listman.redhat.com/mailman/listinfo/k12osn
For more info see <http://www.k12os.org>




__________________________________________________
Do you Yahoo!?
Yahoo! Mail Plus - Powerful. Affordable. Sign up now.
http://mailplus.yahoo.com



_______________________________________________
K12OSN mailing list
K12OSN redhat com
https://listman.redhat.com/mailman/listinfo/k12osn
For more info see <http://www.k12os.org>










[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]