[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[K12OSN] Kybd and mse lock at runlevel 5, but not 3



Hello folks,

I've got two x86 clients, all with AT keyboards and PS/2 mice. These are PCs that I've turned into thin clients. Both netboot to runlevel 3 and I get keyboard and mouse functionality. Both also netboot to runlevel 5, and on one of them I get full keyboard and mouse functionality. On the other one, once X11 starts, the numlock light, which had previously been lit, goes dark, and though I get the K12LTSP login screen, the keyboard and mouse act as if they had been physically unplugged, so Ctrl-Alt-F1 doesn't work to get a CLI login prompt. I do not believe that the thin client has, for lack of a better word, "crashed", because after X11 starts, then it takes a couple more seconds for the GUI login prompt to show up, and about 3 seconds later, the default background bitmap shows up. The X11 screen blanker kicks in after a few minutes, too.

So, I tried changing K12LTSP to start clients in runlevel 3. For my problem child thin client, this worked nicely; I got to a command prompt and had full keyboard functionality. Then I typed startx, and the instant X11 came up, I lost my keyboard again. Had to a hard reboot to recover. I also noted that when I told K12LTSP to boot clients at runlevel 4, then numlock, scroll lock, and (only on the problem child) capslock would work, but nothing I typed would show up on the screen.

Here are the hardware configurations of both thin clients.

The Behaver
---------------
No-name x86 motherboard
K6-166 CPU
80MB 72-pin DRAM
floppy drive
AT keyboard
PS/2 mouse
S3 ViRGE video board (Diamond Stealth 2000 3D, PCI)

The Problem Child
---------------------
Tyan S1590S Trinity X86 motherboard
K6-2/400 CPU
256MB SDRAM
floppy drive
AT keyboard
PS/2 mouse
S3 Trio64 (Diamond Stealth64, ye olde warhorse) video board

I have verified that both keyboards and both mice are good, because they all work fine on The Behaver. Both keyboards and mice stop working at runlevel 5 on The Problem Child. I also swapped video boards, so that The Behaver had the Trio64 and The Problem Child had the ViRGE. The Behaver still behaved, and The Problem Child still lost keyboard and mouse.

Of course you're wondering, why didn't he simply chalk it up to a bad motherboard? Because, again, this happens only at runlevel 5 on K12LTSP. When I do runlevel 3, everything works (no GUI though, of course). When I boot Slackware Linux (this guy also has a hard disk w/ Slackware 8.1 on it), everything works perfectly. Heck, I even put Windows 95 on the thing temporarily, just to make doubly sure, and everything worked perfectly. So I don't believe it's the motherboard at this point.

Has anyone else run into this or have any idea how to fix it?

--TP





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]