[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[K12OSN] Packaging bugs in K12LTSP v3.0.0



I introduced a rather annoying bug into the packaging of three rpms in
K12LTSP 3.0.0. The side-effect of this bug is that it makes it difficult
to upgrade these three particular packages. 

I have uploaded fixed RPMS, but due to the nature of my mistake the
automated package tools will not work here. Up2date, apt, yum, even
upgrading to a newer version of K12LTSP or RedHat will not fix these
packages. The upgrade must be done by hand.

Login in as root, pull up a command shell and follow these steps to
install the fixed packages...

For the experienced administrators, here are the packages that must
be upgraded. If a normal upgrade does not work, do a "--force" upgrade:
   ftp://k12linux.mesd.k12.or.us/apt/8.0/RPMS.k12ltsp/apt-0.5.4cnc9-fr1.k12ltsp.3.i386.rpm
   ftp://k12linux.mesd.k12.or.us/apt/8.0/RPMS.k12ltsp/apt-devel-0.5.4cnc9-fr1.k12ltsp.3.i386.rpm
   ftp://k12linux.mesd.k12.or.us/apt/8.0/RPMS.k12ltsp/anaconda-8.0-4.ltsp.4.i386.rpm


If the above paragraph does not make sense to you, here are the detailed
instructions:

APT
===

First, check to see if the "apt" package is installed:

	# rpm -q apt
	apt-0.5.4cnc9-fr1.k12ltsp.2

If the "rpm -q apt" query returns nothing or something other than
"apt-0.5.4cnc9-fr1.k12ltsp.2", skip down to the ANACONDA section

If you do have "apt-0.5.4cnc9-fr1.k12ltsp.2" installed, please run
this command:

	rpm -Uhv ftp://k12linux.mesd.k12.or.us/apt/8.0/RPMS.k12ltsp/apt-0.5.4cnc9-fr1.k12ltsp.3.i386.rpm

The output should look like this:

  # rpm -Uhv ftp://k12linux.mesd.k12.or.us/apt/8.0/RPMS.k12ltsp/apt-0.5.4cnc9-fr1.k12ltsp.3.i386.rpm
  Retrieving ftp://k12linux.mesd.k12.or.us/apt/8.0/RPMS.k12ltsp/apt-0.5.4cnc9-fr1.k12ltsp.3.i386.rpm
  Preparing...                ########################################### [100%]
     1:apt                    ########################################### [100%]

Depending on how much bandwidth you have and how busy the server is, this
may take a few minutes to run.

If you get a message such as:

	error: Failed dependencies:
        apt = 0.5.4cnc9-fr1.k12ltsp.2 is needed by (installed) apt-devel-0.5.4cnc9-fr1.k12ltsp.2


You will need to update both apt and apt-devel at the same time:

  # rpm -Uhv ftp://k12linux.mesd.k12.or.us/apt/8.0/RPMS.k12ltsp/apt-0.5.4cnc9-fr1.k12ltsp.3.i386.rpm  ftp://k12linux.mesd.k12.or.us/apt/8.0/RPMS.k12ltsp/apt-devel-0.5.4cnc9-fr1.k12ltsp.3.i386.rpm

You should now see output such as:

   # rpm -Uhv ftp://k12linux.mesd.k12.or.us/apt/8.0/RPMS.k12ltsp/apt-0.5.4cnc9-fr1.k12ltsp.3.i386.rpm  ftp://k12linux.mesd.k12.or.us/apt/8.0/RPMS.k12ltsp/apt-devel-0.5.4cnc9-fr1.k12ltsp.3.i386.rpm
   Retrieving ftp://k12linux.mesd.k12.or.us/apt/8.0/RPMS.k12ltsp/apt-0.5.4cnc9-fr1.k12ltsp.3.i386.rpm
   Retrieving ftp://k12linux.mesd.k12.or.us/apt/8.0/RPMS.k12ltsp/apt-devel-0.5.4cnc9-fr1.k12ltsp.3.i386.rpm
   Preparing...          ########################################### [100%]
      1:apt              ########################################### [ 50%]
      2:apt-devel        ########################################### [100%]


If you get an error message saying that package apt-0.5.4cnc9-fr1.k12ltsp.2.i386.rpm is newer than apt-0.5.4cnc9-fr1.k12ltsp.3.i386.rpm, you will have to
force-install the new apt package:

    rpm -Uhv --force ftp://k12linux.mesd.k12.or.us/apt/8.0/RPMS.k12ltsp/apt-0.5.4cnc9-fr1.k12ltsp.3.i386.rpm



ANACONDA
========

Anaconda is not installed by default, but it may have been installed if
you opted to "install all packages" or otherwise manually selected it.

Check to see if the "anaconda" package is installed:

	# rpm -q anaconda
	anaconda-8.0-4.ltsp.3

If the "rpm -q anaconda" query returns "anaconda-8.0-4.ltsp.3", the
updated package can be installed with this command:

    rpm -Uhv ftp://k12linux.mesd.k12.or.us/apt/8.0/RPMS.k12ltsp/anaconda-8.0-4.ltsp.4.i386.rpm

The output of this command should look like this:

   # rpm -Uhv ftp://k12linux.mesd.k12.or.us/apt/8.0/RPMS.k12ltsp/anaconda-8.0-4.ltsp.4.i386.rpm
   Retrieving ftp://k12linux.mesd.k12.or.us/apt/8.0/RPMS.k12ltsp/anaconda-8.0-4.ltsp.4.i386.rpm
    Preparing...             ########################################### [100%]
       1:anaconda            ########################################### [100%]


If you get an error saying that package anaconda-8.0-4.ltsp.3 is newer
than anaconda-8.0-4.ltsp.4, you will need to force-install the new package:

	rpm -Uhv --force ftp://k12linux.mesd.k12.or.us/apt/8.0/RPMS.k12ltsp/anaconda-8.0-4.ltsp.4.i386.rpm


-Eric





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]