[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] OpenOffice hangs on startup w/ "solution" for archives



On Thu, 23 Jan 2003, Dan Young wrote:

>I was having problems w/ OpenOffice failing to start for a couple of
> users last week. It started fine for most users; just a couple were
> experiencing problems.
>
>After starting "oowriter" or any other Ooo program from the console,
> "Starting OpenOffice.org..." would display in the console, but the
>splashscreen would never show up.
>
>I tried deleting their ~/.openoffice directory, without success.
>
>"strace oowriter" found that it stopped loading as it was trying to
>access "/tmp/OSL_PIPE_<xxxx>_SingleOfficeIPC_<xxxxxxxx>", where
><xx...>  is a random number. I deleted the one owned by the user
>having the  problem and oowriter (et al) started right up.
>
>I'm now planning to purge those files nightly via cron. I haven't
>filed  a bug report at openoffice.org yet, nor tried the 1.0.2
>maintenance release.

Another odd one I saw with OOo this week was caused by permissions
on /home.  In K12LTSP 2.1 at least (haven't tried this with v3.0.0),
OpenOffice requires group read access to /home. By default that is
not a problem, but if you change the group ownership of /home and
remove the global read rights....

The results were that OOo would start, but then an error screen would
pop up saying that the config was corrupt and asked the user if they
wanted to delete or repair the install. Selecting either choice would
result in the same error dialog reappearing when OOo was restarted.
"chmod a+r /home" made the problem go away.

-Eric





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]