[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[K12OSN] package management screwed up



The RH8 package manager (Menu->System Settings->Packages) on my server (ver. 3.0.1) was getting hung-up at the point of reading the package headers. I killed it with xkill, tried again, same thing. So, I ran 'rpm --rebuilddb' thinking there was something wrong with the package database. That finished after a few minutes, but now when I run the package manager, it quickly dies with this message:

[root shawn root]# /usr/bin/redhat-config-packages
rpmdb: /var/lib/rpm/Packages: unsupported hash version: 8
error: cannot open Packages index using db3 - Invalid argument (22)
Traceback (most recent call last):
File "/usr/share/redhat-config-packages/MainWindow.py", line 159, in ?
hdlist.mergeRpmDb()
File "/usr/share/redhat-config-packages/hdrlist.py", line 32, in mergeRpmDb
db = rpm.opendb(0, instPath)
rpm404.error



Anyone know how to fix this?


Petre




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]