[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] Multiplayer games possible?



Bill,

I did a play-by-play, indeedie, we're not quite ready for prime time. 
Of the below, BZFlag seems about it for now.
***

>Bah! :^)  Okay, some may be too hard:

  Advanced Strategic Command:  (RTS game)
  http://www.asc-hq.org

 3 errors; needs
libparagui-1.-.so.0
libphysfs-0.1.so.7
libSDLmm-0.1.so.8

  Mangband:  (Multiplayer 'Angband' RPG game)
  http://mangband.org/

http://mangband.org/download/
Source (updated 1/12/03) Consolidated Source.
else, seems to be Win stuff.

  Freeciv:  ('Civilization' clone)
  http://www.freeciv.org/

played with this on a good bit, trying to figure out in/out ports. Live behind 
a firewall ;) So it's installed, -but-

Some may need OpenGL:

  ADIC (Any Door is Closed):
  http://adic.berlios.de/

adic-bin-linux-framebuffer-i586-static-0.9.4.tar.gz
File-roller'd this to a folder, 

dbl-clicked:
startclient --> terminal, quickly showed, exited.
startserver --> termainl, displays Up:     4.59 FPS:  87.20 Frame:      399   
.. what do ya do with this?

-from README:
This is a hack !
This version runs directly on the linux framebuffer
Perhaps you have to set SDL_NOMOUSE
You probably really want to download the "normal" version !!
  ??? where to go next ??? for a 'normal' ver?


  armagetron:  ("Tron" 'light-cycles' game)
  http://armagetron.sourceforge.net/

attempt install:
armagetron-0.2.4-2.i386.rpm
"package not found"
libg++-libc6.2-2.so.3

armagetron-dedicated-0.2.4-2.i386.rpm
 appeared to go in smoothly; nothing new in the 'games' portion of the menu. No 
idea where this critter was installed, etiher. 

[root ltsp brad]# cd /
[root ltsp /]# find armagetron
find: armagetron: No such file or directory

Nothing gained using the graphical "search for files". ???


  BZFlag:  ('Capture the flag' with 3D tanks)
  http://BZFlag.org/

i386 rpm gcc3 ABI (redhat 8+)  1.7g2  2003-06-17 13:22
    bzflag-1.7g2-1.i386.rpm
 OK! We're going somewhere now - hit a server in .de-land, all seemed ok. Now 
tried on WS004 (boo!)
 Xlib: extension "GLX" missing on display "wsoo4.ltsp:0.0"
 Hmmmmm. What would correct this?


But not ALL of them do:

  Maelstrom 3.0:  ('Asteroids' clone; now multiplayer)
  http://www.devolution.com/~slouken/Maelstrom/

Ok, that went well! ;) on the server,and on ws004 ! Woo-Hoo, may be time to 
beckon the Resident Teenager, "Do-Aller" of all things game ;) and try for a 
www session.

  Mah-Jong:
  http://www.stevens-bradfield.com/MahJong/

 This was on the K12LTSP, hence installed. So I'm wondering about multi-player. 
Will research at the website.


  Bomber Instinct:  ('Bomberman' clone)
  http://bomberinstinct.sourceforge.net

BomberInstinct-0.8.9.tar.gz
[brad ltsp BomberInstinct-0.8.9]$ ls
acinclude.m4            docs            LISEZMOI.Spred  pk
aclocal.m4              GPL             locale          README
AUTHORS                 gpl-fr.html     log.txt         README.Nived
BomberInstinct.spec.in  INSTALL         Makefile.am     README.Spred
ChangeLog               install.bat     Makefile.in     scenario.txt
configure               install.PIF     missing         Spred.reg
configure.in            install-sh      mkinstalldirs   src
COPYING                 LISEZMOI        NEWS
data                    LISEZMOI.Nived  Nived.reg
[brad ltsp BomberInstinct-0.8.9]$ ./install
bash: ./install: No such file or directory
[brad ltsp BomberInstinct-0.8.9]$ su
Password:
[root ltsp BomberInstinct-0.8.9]# install.bat
bash: install.bat: command not found
[root ltsp BomberInstinct-0.8.9]# install-sh
bash: install-sh: command not found
[root ltsp BomberInstinct-0.8.9]# mkinstalldirs
bash: mkinstalldirs: command not found
[root ltsp BomberInstinct-0.8.9]#

 I do not know where to go next with this. 


  Batalla Naval:  (You sunk my...!)
  http://batnav.sourceforge.net

Looks good on the screen shots - untarred this and now 35 files to deal with. 
Just a Win dummy, will have to learn about all this 'make' stuff.


  Bots'n'Scouts:  (Robot programmer; based on a board game, I think)
  http://botsnscouts.sourceforge.net/index.php3

 Hmmmm, 'all java' sounded promising, however:
[root ltsp botsnscouts-0.8.2]# ls
botsnscouts.jar  INSTALL    README             start.sh        tileeditor.sh
COPYING          KNOWNBUGS  README.fullscreen  SYSTEMREQ       tiles
fullscreen.sh    lib        start.bat          tileeditor.bat
[root ltsp botsnscouts-0.8.2]# start.sh
bash: start.sh: command not found
[root ltsp botsnscouts-0.8.2]# start.bat
bash: start.bat: command not found
[root ltsp botsnscouts-0.8.2]# INSTALL
bash: INSTALL: command not found
[root ltsp botsnscouts-0.8.2]# ./INSTALL
bash: ./INSTALL: Permission denied
[root ltsp botsnscouts-0.8.2]#

 Again, surely there's some steep learning to do here.

  ClanBomber:  ('Bomberman' clone)
  http://clanbomber.sourceforge.net/

 AHA! an RPM ... these at least have a chance against a M$-inflickted mind ;)  
Alas, (sigh) 'Packages not found ..." and 4 items listed.

  Europa:
  http://europa.mochasoft.ca/
ok, "log in & play" ... now must get java2 plugin ...
Error encountered -- -202 krrrrr! Does a lonnnnng download, and then the error. 
Gives a link to DL the M$ plugin, but none for linux. Possibly because it's a 
Netscape plugin, or possibly wanted a port on my firewall. Hmmmm .... Tried 
this about 5-6 times, same error.

  Liquid War:  (Bizarre game; worth looking at!)
  http://www.ufoot.org/liquidwar

 Yee-haw, another RPM. </HOPE!> (sigh) nothing on the menu, can't find from 
cmdline liq+TAB ... did an updatedb ... liq+TAB = no dice. 

 [root ltsp brad]# cd /
[root ltsp /]# find liquid*
find: liquid*: No such file or directory
[root ltsp /]# find liquid
find: liquid: No such file or directory
[root ltsp /]# find liquid???
find: liquid???: No such file or directory
[root ltsp /]# find liquid

 GUI only found a .jpg using liquid*  Where do these things go? Seemed to 
install OK, but???

  NJam:  (Multiplayer 'Pac-Man' clone)
  http://njam.sourceforge.net

njam-0.96-i386.tar.gz
/home/brad/njam-0/njam-0.96-i386/INSTALL
 INSTALL sez: When ready, unpack the source to any folder, and run: make

 Ok, I'll byte -
[root ltsp njam-0.96-i386]# make
make: *** No targets specified and no makefile found.  Stop.
[root ltsp njam-0.96-i386]#

***
So, we'll keep on plugging.

Thanks,
/b










[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]