[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] dhcpd on fresh LTSP3.1.1 running, but no offers



> > so the main problem now? the new DES 1009G switch sees the i840 NIC, but
> > does not appear to pass PXE.

<snip>
> A switch can spend up to a minute doing spanning-tree negotiations when
> a port first comes up before it will forward any packets out.  I'd
> guess the PXE boot code in ROM is timing out before the switch starts
> sending anything through. 

<snip>

the saga continues... i was having a large fit of
"i'll-find-something-in-the-junkbox-to-make-it-work" and decided to try
my twisted 5.25" solution. found a good (looking) spare loose 5.25"
drive i had, and wrote a 5.25" etherboot floppy. (yes, i have a Mandrake
9.1 box with a working 5.25" floppy. don't ask, i'm just odd like that).
it booted in the Mandrake one, complained for not seeing the correct
NIC, all looked good.

i hauled the drive/cable/floppy upstairs (this is a home/demo/test
server), thinking of what good conversation material the little door on
the front of the IBM Netvista case would be, to flip open and show the
5.25" boot floppy in the (otherwise) diskless LTSP terminal.  remember i
said that i had just barely gotten the i810 one running and wasn't too
familiar with it? NO FLOPPY PORT. argh.

i then decided to write an etherboot boot CD and put a CD drive in the
i810 to test. i got all wound up with mkisofs/El Torrito and getting a
boot.catalog written properly. i had to spend a day or so away from it,
then decided, looking at the rom-o-matic page, that it would be easier
to take a small HD, make a small DOS partition, format /s, then DL the
xxx.com and make a one-liner autoexec.bat that just fired that off. that
should give me the extra time (it is an un-managed switch).

downloaded etherboot xxx.com prog, and configged it to wait for three
minutes (to give the switch plenty of negotation time). dug around in
the junkbox, and found a perfectly good Seagate 272 meg drive. i found a
cd with Winderrs tools on it, made a 10 meg bootable partition, then
booted to Knoppix and made the rest linux swap (if i'm stuck with a HD
in it, may as well try to have some local swap?).

it booted fine, still no DHCP. i took the HD out, put in a cd/Knoppix. i
couldn't manually configure the NIC to see the switch, or use LTSP's
DHCP. ran back downstairs, put the 10mbit hub back on, Knoppix could
then get IP from DHCP and all was well. put the HD back on, the kludge
of DOS/autoexec.bat and etherboot xxx.com worked perfectly.

sooooo..... it's looking like hardware problem. i'll try to call Dlink
tomorrow and find out if there's any thoughts they have. the switch
doesn't appear to pass etherboot, PXE, or just plain TCP/IP stuff from
the i810 onboard NIC. the same switch works fine with other NICS here.

hmm, there is one PCI slot in the i810, and i have a NIC i could try...




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]