[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] ldap problems...HELP!!!



Barry....keep us posted on how yoou make out...I'm watching this thread
with interest.  I haven't run into this yet, but would like to be prepared
should I come across it....Let us know if and how you fix it.

David Trask

k12osn redhat com writes:
>I need to make sense of some problems we are having...
>any help narrowing down our problems would be greatly appreciated at 
>this point...
>I am about out of ideas.
>
>let me know if I should post my config files...
>
>We implemented ldap last year, and the transition went very smooth.
>we were on samba 2.2.8a, and openldap 2.1.17
>so, samba 2.2 schema, and we used the idealix smbldap-tools.
>RedHat 9
>
>I use a windows client ldap browser, to check how our ldap was doing, and
>we were using ldbm backend, with cachesize 1000, and dbcachesize 
>1000000, and it worked great.
>the softerra ldap browser would pop up our 1000 users instantly, and I 
>could click on any of them and get instant results..
>
>we had a server crash, and had to start over from scratch....so, we 
>decided to get samba 3.0 working, in compat mode with
>our samba 2.2 schema.  I went ahead and used the schema file from samba 
>3.0, and modified it, so our ldap entries still worked
>2.2 style.  We still use the idealix smb-tools to add, and delete entries.
>
>The problem is, it works, but we are seeing some erratic behavior out of 
>the server now....
>We have tried, openldap 2.0.27, 2.1.17, 2.1.22, and nothing has fixed 
>the strange things we are seeing.
>
>strange problems:
>1) the softerra ldab browser now takes forever to open and view the ldap 
>directory
>we need to determine why.....softerra comes with openldap.org setup as 
>another ldap directory,
>and their entries pop up instantly....what could we possibly have 
>configured wrong ?
>is this limited to remote queries, or does it affect localhost 
>also...slapcat works instantly...
>no delay there...samba log-ons seem just a tad slower than they did last 
>year, but then again,
>we were very impressed at samba-ldap speed of logins compared to what we 
>had seen with
>samba, and smbpasswd auth
>
>2) since starting over from scratch on the server, re-loading redhat 
>9...our putty terminals
>will drop our shell connections several times during the day....it is 
>very frustrating, and we have no idea what is causing it.
>when it happens, sometimes we can't log right back in, nad have to wait 
>a sec...the strange thing is that this server is the only one doing it...
>all 6 other linux servers have no problems..
>thinking it may be hardware related, we have tried disabling the onboard 
>gigabit nics in our server, and installing 2 new
>gigabit nic's, and we are still seeing the same thing...I have also 
>wondered if it was ldap related, and that ldap was runnign too slow to 
>keep up
>and everynow and then , connections would terminate
>
>3)openldap when we moved to 2.1.21 rpms, and then again on 2.1.22 rpms, 
>gave us an error when database backend was set to ldbm.
>something about not finding the module, but then the module it was aking 
>for was not even on the system.  i looked at the source rpm,
>and the spec file shows --enable-ldbm is there, and nothing about 
>compiling ldbm as a module is in there...so I have no idea about that one.
>we had to specify bdb for those rpms, and the ldap server acted very 
>funny while that was set...timing out on entries, and searches, and
>smbldap-usermod.pl commands....causing database corruption.
>I have since reverted back to apt-getting  openldap 2.0.27 that came 
>with redhat 9.and it is working , but still having strange problems...
>
>so, since I have ldbm working, with 2.0.27, the only thing different 
>from a really great system last year, and this quirky one runnign right 
>now, is the
>samba 2.28a, and samba 2.2 ldap schema...
>
>I am going to revert back to 2.2.8a tommorrow and see if it works as 
>well as it used to, but if anyone can give me more input, I would 
>appreciate it.


David N. Trask
Technology Teacher/Coordinator
Vassalboro Community School
dtrask vcs u52 k12 me us
(207)923-3100




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]