[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[K12OSN] No printing from OpenOffice...FIXED!



Trond Mæhlum wrote:

anthony baldwin wrote:

AHA!! I am having a similar problem! I ran apt-get update/upgrade (using Freshrpm
repositories) on my Shrike box this weekend, and suddenly NO printing from OOo OR Abiword, although I can print from KWord (have not tried printing from a browser or
gimp or any other app, yet). I reinstalled my drivers and OOo, no change


I have also reinstalled printers and OOo to no change. I am totally out here... I have no clue to where to start looking. I am also running a clean shrike with no LTSP packages, since this is my home computer. I am using this list because of the expertise here and since I'm using K12LTSP at our school with great success. I really don't hope this will happen there, because we print from OOo all the time.

I *did not* do that apt-get update thing... It just stopped working. Now I have gotten a little bit furgther. If I start OOo from a console and try to print I get this in the console window:

lpr: unable to create temporary file.

The printer is set via the OOo print-setup tool also. But still no print from OOo. What bothers me is that this worked fine. I have no idea what caused the failure. I am now looking at a fresh install to fix things, or perhaps a K12LTSP upgrade. However, I'm afraid the problem will be carried on into the upgrade, so I fresh install looks like the way to go.

I have fixed my little problem. Here's what I did. I rebooted and booted up on shrike cd 1. I chose upgrade and choose packages to be upgraded. I chose openoffice. There were three packages. I noticed under the install process that openmotif was upgraded also. I think my problem had to be related to that. I recently installed Opera 7 webbrowser. To be able to use the netscape/mozilla plugins, like shockwave and others I had to install an older version of openmotif (openmotif21-2.1.30-6.i386.rpm).


When I come to think of it, it was after that that openoffice refused to print any longer. So now I'm happy as can be. Printing works fine again and the older openmotif libraries needed by Opera are still in function because all plugins work nicely.

The openmotif downgrade is documented on the Opera support pages by the way.

So there you have it.

Trond








[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]