[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] K12ltsp v3.1.2 sound no longer works



On Thu, 2003-10-02 at 01:50, J G wrote:
> Hello,
> 
> I recently upgraded my k12ltsp v3.1.1 to v3.1.2 using
> apt-get upgrade.  Ever since then, my sound no longer
> works.  I have tried esd and nasd (in v3.1.1 esd was
> working for me).  The entries are in the workstation
> definitions of lts.conf (not in the default as per the
> ltsp sound docs).  

You added "SOUND_DAEMON = nasd" to the workstation definitions
rather than default? As per the ltsp sound docs, which you
note, that does not work.


> When I boot a workstation to runlevel 3 the sound
> modules are added successfully and the lsmod lists the
> corresponding sound module.  I try auinfo from the
> server by exporting the AUDIOSERVER variable and I get
> info back (when trying nasd).  I copied auinfo into
> /opt/ltsp/i386/sbin and again in runlevel 3 I run
> auinfo after all modules are loaded and again I get
> info back.

It is working okay on the terminal then. Probably what
you are missing on the server is the LD_PRELOAD settings.
If you add "SOUND_DAEMON = nasd" to the global settings,
the server will set those variables for you. 

> Basically, all appears ok but when I load a game like
> Tuxtype or GCompris - no sound.  As a matter of fact
> Tuxtype audio settings say the sound is disabled.
> 
> Did sound "break" in v3.1.2 or am I just losing my
> mind?


Looks like you just misconfigured it. Try putting SOUND_DAEMON = nasd
in the global section and remove all occurrences of it, or remove it
completely to default back to esd.

If you really get stuck, remove the new sound packages and install the
old...

rpm -e ltsp_esound
rpm -ihv
ftp://k12linux.mesd.k12.or.us/pub/K12LTSP/3.1.1/K12LTSP/RPMS/ltsp_esound-0.3-k12ltsp.2.3.0.i386.rpm


-Eric

Attachment: signature.asc
Description: This is a digitally signed message part


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]