[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] change runlevel in lts.conf doesn't !



Eric,

Duane Wilson installed the newer sound package and it is
correctly launching nasd, so that part is fixed.

BUT, when he logs into Icewm and launches an Xterm it doesn't
show LD_PRELOAD being set.

This indicates that the /etc/profile.d/ltsp-esound.sh is not
being run.

if he runs:   . /etc/profile.d/ltsp-esound.sh
then LD_PRELOAD is set properly.

I'm not sure what is supposed to make the ltsp-esound.sh run
by default.  I looked at /etc/profile, and it is there, and
includes the logic to run all *.sh scripts in /etc/profile.d

SO, i'm guessing that /etc/profile isn't being run.

I modified his /etc/X11/gdm/Sessions/Icewm script
to do:  . /etc/profile.d/ltsp-esound.sh

When I did this, and he logs in, it works.  He gets sound in
the flash player and he's happy.

He's still having a problem with the flash player locking up
on the Jammin-125, but I think that's a different issue.

His i810 workstation appears to be working great, as long
as the line is in the Icewm session script.

So, do you know at what point the profile scripts are supposed
to run ?

I should know this, but i'm tired, and it's not coming to me.

Jim.



On Tue, 7 Oct 2003, Eric Harrison wrote:

> On Tue, 2003-10-07 at 16:15, Duane Wilson wrote:
> > Here they are.
> > 
> > [root klask12ltsp root]# rpm -q ltsp_esound
> > ltsp_esound-0.3-k12ltsp.2.3.0
> > 
> > [root klask12ltsp root]# rpm -V ltsp_esound
> > [root klask12ltsp root]# 
> > 
> 
> This is the older ltsp_esound that does not support NASD.
> 
> Here is the later version that supports NASD:
> 
> ftp://k12linux.mesd.k12.or.us/pub/K12LTSP/3.1.2/K12LTSP/RPMS/ltsp_esound-0.4-k12ltsp.1.3.1.i386.rpm
> 
> 
> -Eric
> 




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]