[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[K12OSN] Followup to network configuration issues



Hello,

Thanks for the suggestions. I've been working on this now for 12 
hours straight and made some progress! I've discovered that the 
onboard gigabit NIC requires you to download the source, make it, and 
then load the resulting 3C2000.o file.

Given that gcc, the linux source, etc are not, by default, installed 
on the ltsp server, I cracked open the installation CDs, installed 
all the necessary files, did a 'make load', isnmod of the resulting 
file, and got it up and running.  To make it appear each time after I 
reboot, I added into  '/etc/rc.d/rc.local' the line insmod
'/usr/src/drivers/3c2000/3c2000.o' which displays it right where I 
should be logging in (annoying, but not a big concern now since I 
just press enter and get another login prompt.) Restarted, and lo-and-
behold, got the LED light in the back to go! I never thought the 
light was so software dependent. 

Of course, DHCP doesn't work this way, since it's looking for eth0 
during the bootup, but won't find it. I got around this by adding to 
the same rc.local file the line 'dhcpd' and volia!  I was able to 
make my laptop boot off its network card, have the server respond, 
pass to the laptop the kernel, etc and everything worked until it 
tried to start X -- bit of screen flashing, and then killed X because 
of improper display settings. BUT I was very happy to have something 
of the server working! Ifconfig shows eth0 now with the correct 
k12ltsp info.

Onword to the PCI realtek card problem. Here the card LED lights up, 
and the switch sees it, etc. but you can't get it to do anything.  
The card is showing up in /proc/pci on Bus 2, device 11, function 0 
correctly as PCI device 10ec:0319

This is even more frustrating when you consider right next to that 
machine is my test pentium II, which has the exact same network card 
and the exact same k12ltsp software (except installed as workstation 
instead of ltsp server) and it's working a-OK! Is there a way to find 
the relevant files and compare them?

I tried using the network control panel to add the eth1 hardware, and 
when I select RealTek RTL8319 from the pulldown menu, then click OK, 
I get:
'the ethernet card could not be initialized.'
and then below that, where it tries to load the file 8319too.o it 
shows 'init_module: no such device'
and
'insmod 8319too failed'

I clicked ok for that, and it was added as an inactive device. When I 
tried to activate it, I receive the error:
'Cannot activate network device eth1!'
followed by:
'8139too device eth1 does not seem to be present, delaying 
initialization'

When you type 'ifconfig eth1' you get:
'eth1: error fetching interface information: Device not found'

And 'modprob 8139too' fails with similar series of errors - either 
failed or no such device.

I'm sort of at a loss here. Any help is much appreciated!

In terms of the kind people's suggestions:

> From: Les Mikesell <les futuresource com>
> To: k12osn redhat com
> 
> Just guessing, but poke around in the bios setup to see if it
> had a setting for 'PNP OS' and set it to 'no' if there is.  Also
> make sure the motherboard NIC is enabled.
> 
> Then boot into Linux and see if 'dmesg' shows the cards being
> detected and assigned to eth devices.
> ---
>    Les Mikesell
>     les futuresource com

Made sure PNP OS was set to 'no'.  When I type dmesg I get a whole 
load of info, but the parts pertaining to this are:
'eth0: 3COM Gigabit LOM' and its details but nothing about eth1


> From: jam mcquil com
> To: k12osn redhat com
> Subject: Re: [K12OSN] Different network configuration?
> Reply-To: k12osn redhat com
> 
> Joseph,
> Run this on the server:
> 
>    lspci -n
> 
> That will show all of the pci devices detected.
> The Class 0200 devices are the Ethernet interfaces.
> Send us the output, and we can tell you what is being found
> in your machine.

Did that, and got 2 Class 0200 devices:

a) 02:05.0 Class 0200 10b7:1700 (rev 12) [I believe that's the 3Com]
b) 02:0b.0 Class 0200 10ec:0139 (rev 10) [should be realtek]

Thanks again,
Joseph




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]