[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] Followup to network configuration issues



On Wed, 15 Oct 2003, Joseph Bishay wrote:

> Onword to the PCI realtek card problem. Here the card LED lights up, 
> and the switch sees it, etc. but you can't get it to do anything.  
> The card is showing up in /proc/pci on Bus 2, device 11, function 0 
> correctly as PCI device 10ec:0319

A standard rtl8139 card should be 10ec:8139

I went to the PCI database, and I see that 10ec:0139 is a valid
card, but it is listed as new, so if your card is 10ec:0139,
then it's very possible that your realtek card is very new,
and not yet supported by the Linux kernel.

I looked at the rtl8139 AND the 8139too driver source code
for the 2.4.22 Linux kernel, and it appears that a realtek
card with a vendor:device value of 10ec:0139 is NOT yet supported


Take a look at:   http://www.yourvote.com/pci/

that's a great site for looking up pci vendor and device ID numbers.


I have seen bad cards that report the wrong PCI values.  usually
reseating the card clears up the problem.

On your P-II, do the same 'lspci -n' command and see what you
get for the PCI values.



> 
> This is even more frustrating when you consider right next to that 
> machine is my test pentium II, which has the exact same network card 
> and the exact same k12ltsp software (except installed as workstation 
> instead of ltsp server) and it's working a-OK! Is there a way to find 
> the relevant files and compare them?
> 
> I tried using the network control panel to add the eth1 hardware, and 
> when I select RealTek RTL8319 from the pulldown menu, then click OK, 
> I get:
> 'the ethernet card could not be initialized.'
> and then below that, where it tries to load the file 8319too.o it 
> shows 'init_module: no such device'
> and
> 'insmod 8319too failed'

If the card is too new, and not yet supported, the error you are
getting is to be expected.


> 
> I clicked ok for that, and it was added as an inactive device. When I 
> tried to activate it, I receive the error:
> 'Cannot activate network device eth1!'
> followed by:
> '8139too device eth1 does not seem to be present, delaying 
> initialization'

Again, see above info.


I hope that helps shed some light on the problem.

Jim McQuillan
jam Ltsp org




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]