[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] Total loss! Why the gray screen again?



The gray screen is almost always a DNS issue where the ip #'s have been
changed from the defaults.

The default is to have eth0 be at 192.168.0.254 with eth1 being the
gateway card to the rest of your network.

>From what you've written below, those are reversed.

;-) Paul

On Wed, 2003-10-22 at 16:37, Joseph Bishay wrote:
> Hello,
> 
> I'm going nuts here and I'm hoping to get a solution soon. The school 
> is desperate and most likely we'll have to switch back to the old Win 
> 98/NT setup if this isn't working soon.  But for the interest of the 
> archives, which I've found very useful, I'll reply to comments here. 
> Any other people's comments are most appreciated.
> 
> > Message: 3
> > Date: Wed, 22 Oct 2003 15:39:45 -0400 (EDT)
> > From: jam mcquil com
> > To: k12osn redhat com
> > Subject: Re: [K12OSN] Total loss! Why the gray screen again?
> > Reply-To: k12osn redhat com
> > 
> > > 3) in /opt/ltsp/i386/etc/lts.conf variable SERVER is set to
> > > 192.168.0.254  Just to make extra-sure, I added XDM_SERVER and set
> > > it to the same address
> > Hmm, with or without XDM_SERVER it should be fine
> 
> That's what I thought, but I was grasping at straws
> 
> > > [00:05:2d:00:15:b2]
> > > # In the Compaq deskpro with 64 M Ram
> > > 
> > > 	XSERVER = auto
> > > #	X_MODE_0 = 640x480  31.5 640  664  704  832  480 489 492 520
> > > #+hsync +vsync 	X_MODE_1 = 800x600  40   800  840  968  1056 600 601
> > > #605 628 +hsync +vsync 	X_MODE_2 = 1024x768 44.9 1024 1048 1208 1264
> > > #768 776 784 817 interlace
> > > 
> > > 	X_MOUSE_PROTOCOL	= "PS/2"
> > > 	X_MOUSE_BUTTONS		= 2
> > > 	X_MOUSE_DEVICE		= "/dev/psaux"
> > > #	X_MOUSE_EMULATE3BTN	= 'Y'
> > > 	RUNLEVEL		= 5
> > > 
> > > The workstation just loads with the gray screen, and the mouse
> > > cursor, which moves no problem if you move the mouse. I have tried
> > > both with the X_MODE_0 line commented and uncommented.  Watching
> > > tail -f /var/log/messages shows nothing - just that it switched to
> > > runlevel 5 and that's it.
> > 
> > The X_MODE_0 is completely out of the picture at this point.  You
> > obviously have X running, because you are getting the gray screen.
> 
> I noticed that it would connect sometimes with the X_MODE_0 commented 
> out, and sometimes when uncommented. As you said, seems it doesn't 
> matter.
> 
> > What is the IP address of the workstation and the server ?
> > How many network cards on the server ?
> > If multiple cards, which one is the LTSP network, eth0, eth1,... ?
> 
> 2 network cards.  
> The server's LTSP IP is the default one of 192.168.0.254, set up on 
> eth1 (Bcasting on 192.168.0.255).
> Eth0 is set to 192.168.1.10 (Bcast on 192.168.1.255) which is one of 
> the IPs that the gateway will accept.
> 
> When I was able to get the workstation to connect, I was easily able 
> to connect to the internet while on the workstation and the server 
> simultaneously, so I believe all the IPs are correct.
> 
> > Try this on the server:
> >    tcpdump -i eth0 -s 1520 -w /tmp/tcpdump.out host 192.168.0.1
> > The command above is assuming that your Ethernet interface is eth0 and
> > your workstation IP address is 192.168.0.1
> 
> So in my case I put in:
> tcpdump -i eth1 -s 1520 -w /tmp/tcpdump.out host 192.168.0.251 (based 
> on how the DHCP server is handing out the IP addresses
> 
> > Then, with the above command running, boot the workstation all the way
> > to the point of getting the gray screen.
> 
> Check.
> 
> > Then, kill the tcpdump command and gzip the /tmp/tcpdump.out file and
> > email it to me at jam Ltsp org
> 
> That's a pretty big file. Guess now is as good a time as any to read 
> the man page on gzip!
> 
> Sent the file just now
> 
> > I'll take a look at what is going on.
> > Jim McQuillan
> > jam Ltsp org
> 
> Thanks so very much.
> 
> 
> _______________________________________________
> K12OSN mailing list
> K12OSN redhat com
> https://www.redhat.com/mailman/listinfo/k12osn
> For more info see <http://www.k12os.org>
-- 
======================================================================
Paul Nelson.............................. pnelson riverdale k12 or us
Riverdale High...........9727 SW Terwilliger Blvd. Portland, OR 97219
voice(503)892-0722...fax(503)892-0723.. http://hs.riverdale.k12.or.us




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]