[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] Sound on VIA epia C3-533



--- Eric Harrison <eharrison mail mesd k12 or us>
wrote:
> >
> >  Sound server informational message:
> >  Error while initializing the sound driver:
> >  device /dev/dsp can't be opened (Permission
> denied)
> >  The sound server will continue, using the null
> >output   device.
> 
> Nasd intercepts calls to /dev/dsp, if you are seeing
> permissions
> problems on /dev/dsp nasd is not working properly.
> 
> Are you using GNOME or KDE? KDE uses artsd for
> sound, which 
> spits out erorrs when logging in from a terminal
> (but sound
> will work in non-arts apps).
> 
> >How do I correct the problem. I'm running K12LTSP
> >3.1.1 and have been using up2date to keep the
> system
> >current.
> 
> * run "rpm -q ltsp_esound", if you are not running
> version 0.4 or
>   later nasd will not work.

I now am subscribed to the K12LTSP channel on RHN and
have ltsp_esound at version 0.4. I still get the error
above in KDE and a slightly different in GNOME.

> 
> * Be sure that you have "SOUND_DAEMON" defined only
> in the Defaults
>   section of lts.conf, it can break things if you
> add it a particular 
>   workstation's section.

I only have SOUND_DAEMON set in the Defaults section.

> 
> * Sound is disabled for root, you have to test it as
> a regular user

This is good to know.

> 
> * Does the terminal pause during bootup and display
> a message that
>   the sound card was not found?

I never did see a pause with an error. It seems to
detect the sound card, A97 or something, and starts
the speakers buzzing a strange clicking buz. Others
have reported this. As soon as I run something like
TuxType the buzzing stops and is fine until the
terminal is rebooted.

> 
> * What is the output of "echo $AUDIOSERVER"  and
> "echo $LD_PRELOAD"?

I get a blank line on both of the echo commands
whether run from root or a regular user's account.
Right now programs like TuxType have sound but I don't
get anything from websites with Flash Apps and I can't
get the volume app to work. Any ideas.

Thank you.



=====
David D. Nelson
nelsda yahoo com

__________________________________
Do you Yahoo!?
Exclusive Video Premiere - Britney Spears
http://launch.yahoo.com/promos/britneyspears/




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]