[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] Sound on VIA epia C3-533



On Tue, 28 Oct 2003, David D. Nelson wrote:

>> * run "rpm -q ltsp_esound", if you are not running
>> version 0.4 or
>>   later nasd will not work.
>
>I now am subscribed to the K12LTSP channel on RHN and
>have ltsp_esound at version 0.4. I still get the error
>above in KDE and a slightly different in GNOME.

Good (at least the RHN channel part).

>> * Be sure that you have "SOUND_DAEMON" defined only
>> in the Defaults
>>   section of lts.conf, it can break things if you
>> add it a particular 
>>   workstation's section.
>
>I only have SOUND_DAEMON set in the Defaults section.

And just to make sure, you should have it set as:

	SOUND_DAEMON = nasd


>> * Does the terminal pause during bootup and display
>> a message that
>>   the sound card was not found?
>
>I never did see a pause with an error. It seems to
>detect the sound card, A97 or something, and starts
>the speakers buzzing a strange clicking buz. Others
>have reported this. As soon as I run something like
>TuxType the buzzing stops and is fine until the
>terminal is rebooted.

Your sound card is obviously being detected, so that
part is fine.

>> * What is the output of "echo $AUDIOSERVER"  and
>> "echo $LD_PRELOAD"?
>
>I get a blank line on both of the echo commands
>whether run from root or a regular user's account.
>Right now programs like TuxType have sound but I don't
>get anything from websites with Flash Apps and I can't
>get the volume app to work. Any ideas.

If you run "echo $ESPEAKER" you should get a response.
As far as I can tell you are running ESD rather than NASD.

Make sure you have the SOUND_DAEMON = nasd line correct
and that you have rebooted the terminal.

If it not too painful, you might also want to reboot the
server. I can't think of any reason why this should make
a difference, but it certainly can't hurt.

-Eric




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]