[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] Help with my sound



k12osn redhat com writes:
>On Wed, 2003-10-29 at 06:45, David Trask wrote:
>> Ok...I've gotta' do this.
>> I need to get nasd working so that one of my teachers can use
>Starfall.com
>> 
>> (plus I simply want to get it working anyway)
>> 
>> Here's what I do and know....I'm pretty sure I have the latest esound
>> package (see below)
>> 
>> 
>> [root server root]# rpm -q ltsp_esound
>> ltsp_esound-0.4-k12ltsp.1.3.1
>
>ok.
>
>> I have put SOUND_DAEMON = nasd 
>> in my lts.conf file....once I do that and reboot the terminal....I have
>no
>> sound at all.  (rebooting the server doesn't help either)
>
>Make sure that you have this in the Defaults section, and only in the
>Defaults section. (Fixing this ugliness is what Jim & were working
>on when we were there in Augusta)
>
>> In order to get sound back I have to either comment out that line or
>> delete it...and reboot the terminal and it's fine.  So....
>> 
>> How can I get nasd running?  Just FYI, I'm running 3.1 of
>> K12LTSP...upgraded via apt to essentially 3.12.
>> 
>> Can anyone give me a hand with steps to proceed and get nasd working?
>
>The basic steps are to install ltsp_esound >= 0.4, add "SOUND_DAEMON =
>nasd"
>to the lts.conf global defaults, reboot the terminal.
>
>Standard debugging questions/comments:
>
>* Don't test it as root, remote sound only works for regular user accounts
>
>* Does the terminal pause during boot and display an error about not
>finding
>  the sound card? (probably not in this case, since ESD works)
>
>* Verify that the ltsp_esound package has not been altered:
++++++++++++++++++++++++++
>
>	rpm -V ltsp_esound
this yields the following

[dtrask server dtrask]$ rpm -V ltsp_esound
..?.....   /opt/ltsp/i386/etc/audiolist
>
++++++++++++++++++++++++++++++++
>
>* Open up a terminal and note the output of the following commands:
>
>	echo $AUDIOSERVER
yields nothing
>
>	echo $LD_PRELOAD
nothing
>
>	echo $ESPEAKER

nada
>

+++++++++++++++++++++++++++++++++
>
>* Set a terminal to boot into run level 3 "RUNLEVEL = 3", reboot the
>terminal,
>  and verify that nasd is running:
>
>	ps auxw | grep nasd

gives me
>
536 root	S	grep nasd
>
>  check to see if esd is running while you're at it:
>
>
>	ps auxw | grep esd

gives me

498 root	S	/sbin/esd -public -nobeeps -tcp -port 16001
538 root	S	grep esd
>
>
>-Eric
>



David N. Trask
Technology Teacher/Coordinator
Vassalboro Community School
dtrask vcs u52 k12 me us
(207)923-3100




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]