[K12OSN] Rebuiliding K12LTSP server's kernel with supermount support

Eduardo Robles Elvira edulix at andaluciajunta.es
Mon Apr 5 10:30:10 UTC 2004

Hello K12LTSP people:

I'm trying to rebuild the K12LTSP 4.0 server's kernel with supermount support because I need to make use of supermount (I'm trying to mount remote cdroms transparently, via ENBD). I'm having trouble.

The kernel version suplied with the distro is 2.4.22-1.2135.nptl, I think that it's a modified version of Fedora Core 1 kernel, which also is a modified version of vanilla's kenrel. I've already tried to compile the vanilla kernel but I had problems moving the cursor and maybe there are other problems I haven't still noticed.. I've even tried the 2.6.3 kernel, but it suffered the same problem as 2.4.22 vanilla's one.

I've also tried to rebuild the kernel given in K12LTSP without a modification andv it compiled without a problem.

This are my steps:

$ uname -r
$ su -
# cd /usr/src/linux-2.4.22-1.2135.nptl
# cp -Rf ../linux-2.4.22-1.2135.nptl ../linux-2.4.22-1.2135.nptl-backup
# patch -p1 < supermount-1.2.11a-2.4.22.patch

While patching, as this is not vanilla's kernel, I got only ONE error. It was easy to solve, with a "# kate include/linux/fs.h.rej include/linux/fs".

# cp /boot/config-2.4.22-1.2135.ntl .config

with menuconfig I add supermount support, as a module:

# make menuconfig
# make dep             // No problem here
# make bzImage     // The show starts!
ld -m elf_i386 -T /usr/src/linux-2.4.22-1.2135.nptl/arch/i386/vmlinux.lds -e stext arch/i386/kernel/head.o arch/i386/kernel/init_task.o init/main.o init/version.o init/do_mounts.o --start-group arch/i386/kernel/kernel.o arch/i386/mm/mm.o kernel/kernel.o mm/mm.o fs/fs.o ipc/ipc.o  drivers/acpi/acpi.o drivers/cpufreq/cpufreq.o drivers/char/char.o drivers/block/block.o drivers/misc/misc.o drivers/net/net.o drivers/char/drm/drm.o drivers/net/fc/fc.o drivers/net/appletalk/appletalk.o drivers/net/tokenring/tr.o drivers/net/wan/wan.o drivers/atm/atm.o drivers/ide/idedriver.o drivers/cdrom/driver.o drivers/pci/driver.o drivers/net/pcmcia/pcmcia_net.o drivers/net/wireless/wireless_net.o drivers/pnp/pnp.o drivers/video/video.o drivers/media/media.o drivers/md/mddev.o drivers/isdn/vmlinux-obj.o crypto/crypto.o net/network.o /usr/src/linux-2.4.22-1.2135.nptl/arch/i386/lib/lib.a /usr/src/linux-2.4.22-1.2135.nptl/lib/lib.a /usr/src/linux-2.4.22-1.2135.nptl/arch/i386/lib/lib.a --end-group !
-o .tmp_vmlinux1
drivers/ide/idedriver.o(.text+0x17570): In function `ide_mediactl':
: undefined reference to `get_info_ptr'
make[1]: *** [kallsyms] Error 1
make[1]: Leaving directory `/usr/src/linux-2.4.22-1.2135.nptl'
make: *** [vmlinux] Error 2

I really need supermount support. Can someone help me ? Do you something I should ? Maybe I should ask this to supermount people ? Maybe directly to the kernel's guys? Come on, I really need help :-).


More information about the K12OSN mailing list