[K12OSN] gimp can't find default font - won't start

anthony baldwin anthonybaldwin at snet.net
Mon Apr 12 04:04:23 UTC 2004

I dled a number of fonts and had them working in OOo and KWord.
I then added them to /usr/X11R6/lib/X11/fonts (in a new dir called 
truetype) did ttmkfdir, xset rehash and added them to the font path with 
Then, I tried to start the gimp to see if they were, indeed, now usable 
in the Gimp, as I had suspected/hoped they would be.
Well, the Gimp wouldn't start at all.
I tried to start it from terminal and got:
GTK-Error: ** Unable to find default font.

So, I went back and removed the fonts and directory from 
/usr/X11R6/lib/X11/fonts, redid xfd restart reset the fontpath by doing 
/usr/sbin/chkfontpath -r /usr/X11R6/lib/X11/fonts/truetype
(basically undid all the changes I had done.)
and tried to start Gimp again.
I still get the same msg, can't find default font.
I can't seem to figure out where the config that tells it where to find 
what font for default is.  I can't help but think that if I could find 
that and edit it, I might be back in business.
All the same, I can't imagine what damage I did to cause it to have lost 
it's default font.
Next to a web browser, Gimp is probably the most used application on my 
machine (just look at photodharma.com or how much stuff I now have up on 
kdelook.org).  Getting the gimp up and running again is very important 
to me.
Can anyone help me or point me in the right direction?
Please!  I'll be your best friend!


Anthony Baldwin
Freedom to Learn!

GED$/L/P/FA d? s: a C++ L++ W++ N++ K- w--- M+ PS++
PE-- Y+ PGP- t+ tv-- b++(b++++) D? G e++++ h++ r--- y?

More information about the K12OSN mailing list