[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Solved pivot_root hang was Re: [K12OSN] K12LTSP-4.2.0-Beta2 upgrade



On Fri, 26 Nov 2004 20:18:46 -0500
Jesse McDonnell <jessemcdonnell comcast net> wrote:

[snip glowing report of K12LTSP-4.2.0-beta 2 upgrade]

> Now the problem - the i-openers don't get along with nfs anymore. They boot a home-rolled 2.4.21 nfs-swap patched kernel from flash and connect to the network via a linksys usb100tx adapter. They get an ip address and then hang "doing the pivot_root."  tail -f /var/log/messages shows that dhcp passes the address (192.168.0.6) , the mount request for /opt/ltsp/i386 is authenticated .....and that's as far as it gets. 
> 
>  tcpdump shows that packets are being fragemented and "ip reassembly time exceeded." The output of "tcpdump -i eth0 | grep ws006.ltsp" is below. This happens with the 2.4.21 kernel and another earlier kernel without nfs-swap both of which worked well with earlier versions of ltsp. 
> 
> I played around with hardware (different cat5 cables, different ports on the switch etc.) and replaced the nfs-utils and system-config-nfs rpms with earlier versions but the problem remains. Does the nfs daemon that comes with fc3 run over tcp/ip? Where are the rsize and wsize values of the exported /opt/ltsp/i386 set?  I grepped and found the mount parameters for the swapfiles in rc.sysinit but I cannot track them for the root directory. I'm hoping that adjusting these will allow me to get over this hurdle. 
> 

Posting a solution to my own problem for the benefit of folks with correctly configured setups who will still face the dreaded pivot_root hang. 

After a lot of time reading up on NFS, looking through configuration files and kernel settings, and reading the kernel mailing list archive, the iopeners are booting again. The solution was to nfs mount /opt/ltsp/i386 over tcp/ip rather than using the default udp. This mounting parameter is in the linuxrc of the initrd for the client kernel. (The rsize and wsize values are set there also, but it wasn't necessary to change them from the defaults.)

The implementation of nfs in the 2.6.x kernel used in FC3 results in timeouts and hanging under network conditions that were not a problem with the 2.4 kernel. Swapping out the usb network adapter for something faster was not possible but a decent nic is clearly the optimal solution. With the iopener a usb nic is as good as it gets!  


Jesse McDonnell


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]