[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] hotplug issue



eharrison mail mesd k12 or us wrote:

On Sat, 4 Dec 2004, norbert wrote:

Are you referring to this?
http://pxes.sourceforge.net



Yes that's the CD I'm using however I'm using K12ltsp on the server..



If you are using pxes, client-side problems probably need to be reported to the pxes folks.

PXES *replaces* the K12LTSP client boot process, having K12LTSP on
the server doesn't really matter in this case.

Hopefully that makes sense ;-)



The problem is specific ot 4.2 since the CD work fine with both 4.0.1 & 4.1.1 therefore I must conclude that something has changed on the server side ???? But as I mentionned in my last email I'm getting the same problem with a boot floppy also.....

.....and that doesn't make sense :-D


In LTSP/K12LSTP, the client uses BOOTP/PXE to download a kernel and
an initial ram disk. The initial ram disk contains software to NFS
mount the server and to execute the LTSP software via NFS. The X
server the client runs, for example, is located on the NFS share.

PXES is self-contained, the boot image contains all of the software
needed, including the X server. NFS is not used at all (and since
the LTSP software is *only* on NFS, PXES never uses the LTSP software).

When you boot via floppy, are you using a LTSP or a PXES image?
If you are getting hotplug errors, it must be PXES since LTSP does
not include hotplug...

Could you post your /etc/dhcpd.conf? That'll help us figure out exactly
what software is running.

-Eric

_______________________________________________
K12OSN mailing list
K12OSN redhat com
https://www.redhat.com/mailman/listinfo/k12osn
For more info see <http://www.k12os.org>

Hi Eric,


I rebuilt the system and found two problems, bad cat5 cable & flawed floppy hence the other issues. So now it starts but when the WS logs in I get what started the whole issue of testing "upgrading" the system. These where errors I had with 4.1.1 and I had installed XFree 4.4 but Jim said that LTSP uses xorg & not XFree86............................

"Error activating XKB configuration.
Probably internal X server problem.

X server version data:
The XFree86 Project, Inc
40300000
You are using XFree 4.3.0.
There are known problems with complex XKB configurations.
Try using simpler configuration or taking more fresh version of XFree software.
If you report this situation as a bug, please include:
-The result of xprop -root | grep XKB
-The result of gconftool-2 -R /desktop/gnome/peripherals/keyboard/xkb"


so ....
xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "xorg", "pc105", "us", "", ""
_XKB_RULES_NAMES(STRING) = "xorg", "pc105", "us", "", ""

and

gconftool-2 -R /desktop/gnome/peripherals/keyboard/xkb"
layout = [us]
model = pc105
overrideSettings = false
options = []
update_handlers = []

Ideas or suggestions ....

thks again

norbert



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]