[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] Yum update ?



eharrison mail mesd k12 or us wrote:

On Thu, 16 Dec 2004, norbert wrote:

Hi Eric,

It's getting late ...

[root krypton adobe]# rpm -q --whatprovides  mozilla-acroread
no package provides mozilla-acroread


Ok.

Resolving dependencies
....Unable to satisfy dependencies
Package mozilla-acroread needs acroread = 5.0.9, this is not available.


Not Ok.

Now I downloaded & installed acroread 5.0.9 & I still get this. Is this message generated from the server ?


No, it is generated by yum.


So here are a couple more things to try:


1) the plugin name is nppdf.so, let's do a search for that and see
   if rpm knows what package it belongs to:

rpm -qf `locate nppdf.so`

2) If not, lets see if we can guess what the mystery package is:

       rpm -qa | grep -i acroread
       rpm -qa | grep -i adobe
       rpm -qa | grep -i mozilla

one of those is bound to list a non-fedora/k12ltsp package

3) I just built acroread-5.0.10 & acroread-plugin-5.0.10 packages,
   try downloading these and running "rpm -Uhv acroread*rpm" on them.
   This will either upgrade the problem package or it is likely
   to give you a conflict error. In the first case: problem solved,
   in the second: problem identified.

ftp://k12linux.mesd.k12.or.us/pub/K12LTSP/testing/RPMS/

-Eric

_______________________________________________
K12OSN mailing list
K12OSN redhat com
https://www.redhat.com/mailman/listinfo/k12osn
For more info see <http://www.k12os.org>

Hi Eric,


Here's the result from those rpm's

[root krypton root]# rpm -qf `locate nppdf.so`
acroread-plugin-5.06-4
acroread-5.06-4
file /usr/local/Acrobat5/Browsers/intellinux/nppdf.so is not owned by any packag e
[root krypton root]# rpm -qa | grep -i acroread
acroread-plugin-5.06-4
acroread-5.06-4
[root krypton root]# rpm -qa | grep -i adobe
[root krypton root]# rpm -qa | grep -i mozilla
mozilla-nspr-1.7.3-0.2.0.k12ltsp.0.4.1
mozilla-1.7.3-0.2.0.k12ltsp.0.4.1
mozilla-mail-1.7.3-0.2.0.k12ltsp.0.4.1
mozilla-nss-1.7.3-0.2.0.k12ltsp.0.4.1


I downloaded and installed the new packages but I still get the same error ??

thks
norbert



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]