[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[K12OSN] need help with local usb print (Unable to send print file to printer: Broken pipe)



Jim McQuillan wrote:

John,

The j125 and the j225 are very different computers, although they fit
inside the same case.

The J125 uses the usb-ohci driver, while the J225 uses the usb-uhci.

PLUS, if you are already using a USB mouse, then you don't need to
bother with loading the usb-uhci, it's already been loaded for the mouse
to work.

Jim McQuillan
jam Ltsp org

On Wed, 29 Dec 2004, John Baillie wrote:

> Hello,
>
> I can't get a local usb printer to work on a Jammin 225.
> The 225 has a static ip assigned in dhcpd.conf 192.168.0.10
>
> This is on ver k12ltsp 4.1.1

-snip--------------------------->

Thanks Jim,

That got me over the first hurdle.

Still not printing though. 

I'm a little gun shy here being I missed the fact that I should 
have been using the usb Universal Host Controller Interface module.

Hopefuly this is something as just as simple that I'm overlooking.

I did see in a usb printing related post on ltsp-discuss where someone mentioned
their particular printer needed to be initialized on power on. Again this is an epson
c84 and I don't think this is the case for this printer.

John

Here is the output from /var/log/messages

################################################
Dec 29 16:53:24 wilborada cups: cupsd -HUP succeeded
Dec 29 16:53:41 ws010.ltsp lp_server: Started with: -n 9100  -d /dev/usb/lp0 -t "9600 ixon ixoff -crtscts -parity cs8 "
Dec 29 16:53:41 ws010.ltsp last message repeated 2 times
Dec 29 17:10:01 wilborada cups: cupsd -HUP succeeded
Dec 29 17:10:14 ws010.ltsp lp_server: Started with: -n 9100  -d /dev/usb/lp0 -t "9600 ixon ixoff -crtscts -parity cs8 "
########################################


and this is the output from the printconf-gui

########################################
I [29/Dec/2004:16:28:17 -0500] Adding start banner page "none" to job 17.
I [29/Dec/2004:16:28:17 -0500] Adding end banner page "none" to job 17.
I [29/Dec/2004:16:28:17 -0500] Job 17 queued on 'printer' by 'root'.
I [29/Dec/2004:16:28:17 -0500] Started filter /usr/lib/cups/filter/pstops (PID 32585) for job 17.
I [29/Dec/2004:16:28:17 -0500] Started filter /usr/lib/cups/filter/foomatic-rip (PID 32586) for job 17.
I [29/Dec/2004:16:28:17 -0500] Started backend /usr/lib/cups/backend/socket (PID 32587) for job 17.
E [29/Dec/2004:16:28:18 -0500] [Job 17] Unable to send print file to printer: Broken pipe
E [29/Dec/2004:16:28:21 -0500] PID 32586 stopped with status 9!
I [29/Dec/2004:16:28:21 -0500] Hint: Try setting the LogLevel to "debug" to find out more.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]