[K12OSN] file upload with php (squirrelmail and other)

Scott Sherrill scott at hancock.k12.mi.us
Tue Jun 22 14:17:20 UTC 2004

this one is pulling out my hair.

Working with file uploads and php --- in part with SquirrelMail and 
also on a custom script I am writing another server.

The SquirrelMail server is running RH9, Apache 2.0.40 and php 4.2.2. 
When a user goes to upload a file as an attachment SM reports back 
Cannot move/copy file.

The SM wiki 
(http://www.squirrelmail.org/wiki/en_US/DirectoryPermissionsProblem ) 
talks about permissions and modifying the php.ini.  Both I am pretty 
sure I have set right.

In /etc/php.ini I have file_upload = On and in 
/etc/squirrelmail/config.php I have the attachment directory set to 
/var/spool/squirrelmail/attach/ which is owned and writeable by 

Still doesn't work.

I put SM on the back burner for awhile, actually I had forgotten 
about it, until just recently when I started working on another 
program (mini photo gallery with file uploads and php).

Different server this one is a RH AS3 box running Apache 2.0.46 and php 4.3.2
Checked /etc/php.ini file_upload = On  I've tried changing the file 
upload location to /tmp and also /tmp/uploads.

I've tried perms on /tmp/uploads of 777 and ownership to apache.

in this case no error, things just don't happen.

I've restarted httpd after every change to php.ini.

I am befuddled and sure I am missing something stupid and obvious, 
but I can't see it.

I appreciate any suggestions -


More information about the K12OSN mailing list