[K12OSN] XFree fatal error 104

Bert Rolston bert.rolston at clear.net.nz
Sun May 9 20:45:02 UTC 2004

Hi Terrell,

I'm posting inline. It's a bit messy but there are several points

Notice that I have a "tty7" entry, and also notice the permissions on 
> it.  My Mandrake 9.2 box also goes up to tty9, BTW.  Since your listing 
> stopped at tty6, we have one of two options that I can think of to try out.

I tried the following.

Move ttyx(9,8,7) to tty(4,5,6) to coincide with the missing ones. No

Not sure if this was advisable but it didn't seem to break anything

> 1.)  Make a new device node for tty7.  That's kinda ugly, and I'll have 
> to go remind myself how to do it (it's been a while).

I've done this in the past, but only once. I can't remember how, or
where I found the info last time.

> 2.)  Try changing permissions on one of the other tty's to match what my 
> tty7 has on it.  Given that the UID and GID are both root, it shouldn't 
> make a difference, but it's worth a shot.  I'd try it with tty's 4 and 6 
> first, since that's what your XFree86.0.log file shows that X11 is 
> trying before it dies.

Tried this, they get changed back to the settings shown by ls.

> If 2.) doesn't do the trick, then let us know, and I'll go dust off how 
> to make device nodes.  :-)

You've given me a clue here. "device nodes". I couldn't even remember that.


More information about the K12OSN mailing list