[K12OSN] lilo config? MBR hosery? boot issues...

Les Mikesell les at futuresource.com
Fri May 14 22:41:26 UTC 2004

On Fri, 2004-05-14 at 17:19, anthony baldwin wrote:

> I just checked Kdiskfree to take a look at my partition table (make sure 
> that /dev/hda1 was the /boot), and I've noticed that, in addition to 
> whatever is wrong with the MBR or boot loader, my swap partition seems 
> to have completely disappeared.

An upgrade shouldn't change partitions or mount points at all.  Does
/etc/fstab still mention a swap partition?

> I tried to install grub, but apparently I am not translating the man 
> pages correctly.

If everything else is correct, running
as root should do it all for you.  If you try it the hard way
you have to figure out the bsd-style partition name conventions.

> I'm not sure how to recover my swap partition, either.
> This is all rather odd...

I'd be inclined to back up what I could still get from /home and
re-install from scratch, but look at it with fdisk -l and
compare to /etc/fstab and the output of the 'mount' command
to see if you can figure out what happened to your partitions.

   Les Mikesell
    les at futuresource.com

More information about the K12OSN mailing list