[K12OSN] Fedora 1 - doesn't like PS/2 mouse after update

Petre Scheie petre at maltzen.net
Tue May 25 13:40:24 UTC 2004

I noticed some similar strange PS/2 mouse behavior when I went from K12lstp ver 
2.x to ver. 3.1.2.  I have some Microsoft "Basic Mouse" (that's what the box 
says), that worked fine on the server and clients under 2.x.  But when I went to 
3.x they stopped working.  Usually, the mouse will work for the first several 
seconds after logging in but then just freeze up.  I suspect the change in 
XFree86, from 3.x to 4.x, which happened in RH9 I believe, is what caused the 
problem.  I've got other mice, so it wasn't a show stopper.  But these are nice 
mice, relatively new, and at this point I can't use them. So, you might see if 
you can load a 3.x version of X (not sure if Fedora even still includes the old 
version) and see if that makes any difference.


David Beach wrote:
> I wanted to try fedora core 1 (the version I have) on a new computer so
> installed it from my K12LTSP 4 disk set - just checked the 'personal
> computer' option in setup.
> I have an old IBM PS/2 mouse and all worked well - I rebooted and moused
> around a bit and all seemed OK. (the PS/2 mouse worked just fine after the
> initial install so I presume this is not a hardware issue.) So I decided to
> retrieve the updates. I got the kernel and I think some of the other
> updates. Eventually got the lot loaded. BUT, when it boots (now with either
> the old or new kernel) the machine chokes and won't run X. Says it has a
> problem with the mouse. It pops up a clunky window that lets me choose the
> mouse again. Again, I choose 2 buttun generic PS/2 mouse. Again, it doesn't
> work! I eventually end up at the command line.
> When I plug in another mouse on USB, it works OK. If I use the Mouse panel
> and reset to PS/2, the computer refuses to recognize the PS/2 mouse even
> after reboot. So, I could just always use a USB mouse but I'm annoyed the
> PS/2 worked, then didn't. And I have lots of old PS/2 mice but only one USB!
> OK, you bright beans: Why does the computer refuse to work with the PS/2
> mouse? Is there some little file or folder where I can peek to set this
> right?
> (By the way, the motherboard is a Kobian Mercury 740 CFDMx - a nifty miniATX
> board with video, audio, LAN, integrated AMD 2200 processor for about $50
> US. It has an SiS chipset.)
> David Beach
> _______________________________________________
> K12OSN mailing list
> K12OSN at redhat.com
> https://www.redhat.com/mailman/listinfo/k12osn
> For more info see <http://www.k12os.org>

More information about the K12OSN mailing list