[K12OSN] Help....smbldap-installer and roaming profiles....I need help to fix

Henry Burroughs hburroughs at HHPREP.ORG
Mon Feb 7 15:11:57 UTC 2005

I haven't looked at the script, but I can tell you why root is wanting
to log in as Administrator.  Look at the 3rd field in the passwd line...
where it says "0".  That is the UIDNUM for the root user!  I would think
you wouldn't want it setup that way, but I may be wrong considering I
haven't setup a Samba PDC before.

> ______________________________________________________________________
> From: Jim Kronebusch <jim at winonacotter.org>
> To: Support list for opensource software in schools. <k12osn at redhat.com>
> Subject: Re: [K12OSN] Help....smbldap-installer and roaming profiles....I need help to fix
> Date: Sat, 05 Feb 2005 16:11:54 -0600
> > Here's something I've found....it may be nothing...or it may be
> > everything....
> > 
> > when I run     getent passwd     on my current functioning Samba/LDAP
> > server (production box...pre smbldap-installer) I get ...
> > 
> > Administrator:x:0:512:Netbios Domain Administrator:/home/:/bin/false
> > 
> > Where as on a machine I just set up with smbldap-installer....I get...
> > 
> > Administrator:x:0:512:Netbios Domain
> > Administrator:/home/Administrator:/bin/false
> > 
> > Note the difference in "home".  Are you guys seeing this?  I'm having
> > issue running programs like gedit as it wants to write to
> > /home/Administrator, but it isn't there.   I wonder if this is
> > contributing?
> I don't have much time over the weekend but I'll check it out first thing 
> Monday.  But I think your on to something with the home.  I noticed that 
> after running the script, when I rebooted for the first time, I recieved an 
> error when logging onto the server as root.  The message said that it 
> couldn't find the home directory /home/Administrator.  I found that it was 
> odd that it was looking for a home directory of Administrator when I logged 
> in as root and I never set up an Administrator user.  So I figured the 
> script must have modified the root user into Administrator.  Then I logged 
> in with a standard user, did su and created a /home/Administrator folder and 
> chmod and chown so it matched the privs of /root.  Then copied all files and 
> folders from /root to /home/Administrator.  Then logged out and back in as 
> root and the problems were solved.  
> Not sure what all that means but maybe it will give you a clue as to what is 
> happening with the home folders and permissions.  
> I just ssh'ed to my test box and here is the result of getent passwd for 
> Administrator:
> Administrator:x:0:512:Netbios Domain 
> Administrator:/home/Administrator:/bin/false
> -- 
> This message has been scanned for viruses and
> dangerous content by the Cotter Technology 
> Department, and is believed to be clean.

More information about the K12OSN mailing list