[K12OSN] RE: RE: smbldap-installer v. 1.2-gamma gnome login problem

Matt Oquist moquist-k12osn at majen.net
Wed Feb 9 15:08:50 UTC 2005

David Trask wrote:    [Wed Feb 09 2005, 09:30:33AM EST]
> So...once I rebooted...I ran smbldap-usermod -P ctrask  and changed the
> password....this took care of it....I am now able to log in to Gnome. 

Huh.  I thought /bin/false would only disable ssh and virtual-terminal
access, but it looks like even Gnome doesn't log you in if your shell
is /bin/false.  Well, just goes to show that I didn't test this...

Yeah, this is a very bad default value to be in smbldap-useradd-bulk
since it makes the accounts almost useless.  :)

> This is not a critical issue, but I'm wondering if we should change back
> to /bin/bash by default.  I am curious...and haven't been able to try
> it...does this /bin/false make it not possible to log in from a terminal?

I would be surprised if terminal logins worked, though I haven't been
able to test this.

http://majen.net/smbldap-installer-1.2-delta.tgz is now available with
the new docs and a smbldap-useradd-bulk default shell of /bin/bash.
I'll consider this an official release once I've tested it today:
1. use smb-ldap.pl on fresh K12LTSP install
2. mv userinof.start.sample userinfo.start and 'make'
3. join Windblows test box to domain and log in as a test user
4. verify that Windblows profile was created
5. log into LTSP server as test user
6. log into thin client as test user

Once I've done those things I'll move the file to
"smbldap-installer-1.2.tgz" and I'll send out another email.



More information about the K12OSN mailing list